Bug 977394 - mpfr_devel from Optional to to primary Server/Workstation channels
mpfr_devel from Optional to to primary Server/Workstation channels
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mpfr (Show other bugs)
6.5
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Lubos Kocman
BaseOS QE - Apps
: ReleaseNotes
Depends On:
Blocks: 977396 977435
  Show dependency treegraph
 
Reported: 2013-06-24 08:56 EDT by Frantisek Kluknavsky
Modified: 2014-07-01 08:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 977396 977435 (view as bug list)
Environment:
Last Closed: 2013-07-02 08:55:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frantisek Kluknavsky 2013-06-24 08:56:52 EDT
Description of problem:
Developer Toolset v2.0 beta currently requires the user to subscribe to
the Optional channel solely for the mpfr-devel package, which is a
dependency for DTS v2.0 gcc.

Please move mpfr-devel to primary Server/Workstation channels for 6.5/5.10 to remove this extra step for DTS users.
Comment 2 Frantisek Kluknavsky 2013-06-24 10:27:23 EDT
Streams required:
RHEL5: 5.9, 5.10+
RHEL6: 6.2, 6.3, 6.4, 6.5+
RHEL7: 7.0
Comment 5 Lubos Kocman 2013-07-02 08:55:15 EDT
We've discussed this issue deeply within RCM.

It looks like the only way that this package can be installed is directly or by installing devtoolset-2-gcc-plugins-devel.

There is no requires for devtoolset-2-gcc-plugins-devel within the product. So you need to install it directly or trough devtoolset-2*

The common approach is that documentation contains "If you want to install -devel packages then you need to enable optional repo".

The resolution would be not to install devtoolset-2 trough following command:

yum install devtoolset-2*

Devel nack
Comment 6 RHEL Product and Program Management 2013-07-02 08:55:25 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.