Bug 977401 - Difficult to use HyPackage in C for any real-world usage
Difficult to use HyPackage in C for any real-world usage
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: hawkey (Show other bugs)
rawhide
All All
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 09:06 EDT by Richard Hughes
Modified: 2013-06-25 10:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-25 10:39:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that works for me (2.53 KB, patch)
2013-06-24 09:06 EDT, Richard Hughes
no flags Details | Diff

  None (edit)
Description Richard Hughes 2013-06-24 09:06:24 EDT
Created attachment 764595 [details]
patch that works for me

Description of problem:
It's difficult to use HyPackage in C for any real-world usage without wrapping it or maintaining a metadata dictionary.

Patch attached for review. Feel free to hack this about yourself and commit or return with comments for me to re-submit. Thanks.
Comment 1 Richard Hughes 2013-06-25 10:39:01 EDT
I've pushed a patch to fix this.

Note You need to log in before you can comment on or make changes to this bug.