Bug 977406 - Ensure packstack sets 'ovs_use_veth = True' config in /etc/quantum/quantum.conf
Ensure packstack sets 'ovs_use_veth = True' config in /etc/quantum/quantum.conf
Status: CLOSED DUPLICATE of bug 966347
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: async
: 3.0
Assigned To: Terry Wilson
Nir Magnezi
Depends On:
  Show dependency treegraph
Reported: 2013-06-24 09:30 EDT by Kashyap Chamarthy
Modified: 2013-07-03 16:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-03 16:27:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kashyap Chamarthy 2013-06-24 09:30:55 EDT
packstack should ensure set the config directive:

  'ovs_use_veth = True'

in  [DEFAULT] section of /etc/quantum/quantum.conf

Otherwise, it results in (/var/log/quantum/dhcp-agent.log):
Stdout: ''
Stderr: 'RTNETLINK answers: Device or resource busy\n'
2013-06-24 16:55:27     INFO [quantum.agent.dhcp_agent] Synchronizing state
2013-06-24 16:55:27     INFO [quantum.openstack.common.rpc.impl_qpid] Connected to AMQP server on
2013-06-24 16:55:29    ERROR [quantum.agent.dhcp_agent] Unable to enable dhcp.
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/quantum/agent/dhcp_agent.py", line 131, in call_driver
    getattr(driver, action)()
  File "/usr/lib/python2.6/site-packages/quantum/agent/linux/dhcp.py", line 124, in enable
  File "/usr/lib/python2.6/site-packages/quantum/agent/dhcp_agent.py", line 554, in setup
  File "/usr/lib/python2.6/site-packages/quantum/agent/linux/interface.py", line 181, in plug
  File "/usr/lib/python2.6/site-packages/quantum/agent/linux/ip_lib.py", line 180, in set_address
    self._as_root('set', self.name, 'address', mac_address)
  File "/usr/lib/python2.6/site-packages/quantum/agent/linux/ip_lib.py", line 167, in _as_root
    kwargs.get('use_root_namespace', False))
  File "/usr/lib/python2.6/site-packages/quantum/agent/linux/ip_lib.py", line 47, in _as_root
  File "/usr/lib/python2.6/site-packages/quantum/agent/linux/ip_lib.py", line 58, in _execute
  File "/usr/lib/python2.6/site-packages/quantum/agent/linux/utils.py", line 61, in execute
    raise RuntimeError(m)
Command: ['sudo', 'quantum-rootwrap', '/etc/quantum/rootwrap.conf', 'ip', 'link', 'set', 'tap1192cd81-de', 'address', 'fa:16:3e:8e:60:4b']
Exit code: 2
Stdout: ''
Stderr: 'RTNETLINK answers: Device or resource busy\n'
2013-06-24 16:55:59     INFO [quantum.agent.dhcp_agent] Synchronizing state
2013-06-24 16:56:00    ERROR [quantum.agent.dhcp_agent] Unable to sync network state.
Traceback (most recent call last):
Comment 1 Gary Kotton 2013-06-24 09:33:52 EDT
When the parameter is not set and namespaces are used the the message above appears.
Comment 3 Terry Wilson 2013-06-28 14:34:38 EDT
In recent builds, ovs_use_veth=True is set by default when the packages are installed. Gary added it in https://bugzilla.redhat.com/show_bug.cgi?id=966347

I think that it is better to handle this at the package level since the setting isn't needed on Fedora, which has more complete network namespace support. This way we can just let packstack accept whatever the default is from the packaging.

If using the latest puddles/RC on a fresh install do you still run into the issue with this not being set? If on RHEL, it should be set in the /usr/share/quantum/quantum-dist.conf.

If no one has any objections, I'd like to close this as a duplicate of 966347.
Comment 4 Terry Wilson 2013-07-03 16:27:50 EDT

*** This bug has been marked as a duplicate of bug 966347 ***

Note You need to log in before you can comment on or make changes to this bug.