Bug 977443 - Packstack should reconfirm MySQL admin password
Packstack should reconfirm MySQL admin password
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: beta
: 4.0
Assigned To: Ivan Chavero
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 10:49 EDT by Sadique Puthen
Modified: 2013-12-19 19:08 EST (History)
7 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.5.dev740.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:08:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sadique Puthen 2013-06-24 10:49:17 EDT
Description of problem:

Packstack currently does not re-confirm MySQL admin password. There should be a prompt to verify the password and repeat if the verification fails.

Should Packstack install Nagios to monitor openstack hosts [y|n]  [n] : y
Enter the IP address of the MySQL server  [10.65.209.21] : 
Enter the password for the MySQL admin user :
Enter the IP address of the QPID service  [10.65.209.21] : 

This would help users to save themselves from typos when entering passwords.
Comment 2 Ivan Chavero 2013-08-30 04:34:44 EDT
Bug fixed in this review: https://review.openstack.org/#/c/44421/
Comment 4 Omri Hochman 2013-10-13 08:26:01 EDT
Verified with : 
openstack-packstack-2013.2.1-0.6.dev763.el6ost.noarch 
(Havana RHOS 4.0,  puddle - 2013-10-03.3)

Enter the IP address of the MySQL server  [10.35.160.119] : 
Enter the password for the MySQL admin user :
Confirm password :
Error: passwords don't match
Enter the password for the MySQL admin user :
Comment 7 errata-xmlrpc 2013-12-19 19:08:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.