Bug 977450 - [rhevm-reports_33] - Installation - re-installing reports fails when deleting rhevmreports db
[rhevm-reports_33] - Installation - re-installing reports fails when deleting...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: 3.2.1
Assigned To: Yaniv Lavi (Dary)
David Botzer
infra
: ZStream
Depends On: 977360
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 11:06 EDT by Idith Tal-Kohen
Modified: 2016-02-10 14:29 EST (History)
10 users (show)

See Also:
Fixed In Version: rhevm-reports-3.2.1-5.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Previously, if the rhevmreports database was dropped, it was not recreated when rhevm-reports was reinstalled. As a result, rhevm-reports-setup failed during the "Exporting adhoc reports" step. The rhevmreports database is now recreated when rhevm-reports is reinstalled.
Story Points: ---
Clone Of: 977360
Environment:
Last Closed: 2013-07-16 09:28:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
3.2-sf18 (316.42 KB, text/plain)
2013-06-25 10:35 EDT, David Botzer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Ruby 8671 None None None Never
oVirt gerrit 16042 None None None Never

  None (edit)
Description Idith Tal-Kohen 2013-06-24 11:06:50 EDT
+++ This bug was initially created as a clone of Bug #977360 +++

Description of problem:
rhevm-reports-setup - Installation - re-installing reports fails when deleting rhevmreports db

Version-Release number of selected component (if applicable):
3.3/is2
3.2/sf18.1

How reproducible:
always on both version

Steps to Reproduce:
1.install rhevm+dwh+reports
2.run setup for all
3.verify all db's were created
4.yum remove rhevm-reports
5.dropdb rhevmreports
6.Reinstall rhevm-reports
7.run reports-setup

Actual results:
fails - "Failed while exporting ad hoc reports"

Expected results:
Should recreate the rhevmreports db

Additional info:
Occurs also on 3.2

3.2/sf18.1 /rhevm-reports.noarch 0:3.2.1-4.el6ev

rhevm-reports-setup
Welcome to ovirt-engine-reports setup utility
In order to proceed the installer must stop the ovirt-engine service
Would you like to stop the ovirt-engine service? (yes|no): y
Stopping ovirt-engine...                              [ DONE ]
Please choose a password for the admin users (rhevm-admin and superuser):
Warning: Weak Password.
Re-type password:
Editing XML files...                                  [ DONE ]
Setting DB connectivity...                            [ DONE ]
Exporting adhoc reports...                            [ ERROR ]
Failed while exporting ad hoc reports
Comment 3 David Botzer 2013-06-25 10:03:28 EDT
Got some errors installing:
Resolving Dependencies
--> Running transaction check
---> Package rhevm-reports.noarch 0:3.2.1-5.el6ev will be installed
--> Processing Dependency: rhevm >= 3.2.0 for package: rhevm-reports-3.2.1-5.el6ev.noarch
--> Finished Dependency Resolution
 You could try using --skip-broken to work around the problem
** Found 660 pre-existing rpmdb problem(s), 'yum check' output follows:
Comment 4 David Botzer 2013-06-25 10:35:46 EDT
Created attachment 765117 [details]
3.2-sf18

failed new fix
Comment 5 David Botzer 2013-06-26 01:25:37 EDT
3.2/sf18.1
rhevm-reports-3.2.1-5.el6ev.noarch.rpm
Fix is working when installing clean install

Remove reports pacakge & dropdb, than reinstall & run setup
Comment 6 David Botzer 2013-06-26 07:31:34 EDT
Fixed,
Comment 8 errata-xmlrpc 2013-07-16 09:28:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1074.html

Note You need to log in before you can comment on or make changes to this bug.