Bug 977553 - broken symlinks in GCC packages
broken symlinks in GCC packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 17:54 EDT by Harald Reindl
Modified: 2013-06-25 06:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-25 01:44:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2013-06-24 17:54:27 EDT
could somebody please clean this up?

[root@srv-rhsoft:~]$ symlinks -r / | grep dangling | grep gcc
dangling: /usr/lib/gcc/x86_64-redhat-linux/4.7.2/32/libstdc++.a -> ../../../i686-redhat-linux/4.7.2/libstdc++.a
dangling: /usr/lib/gcc/x86_64-redhat-linux/4.7.2/32/libgcc_s.so -> /lib/libgcc_s.so.1
dangling: /usr/lib/gcc/x86_64-redhat-linux/4.7.2/32/libmudflapth.a -> ../../../i686-redhat-linux/4.7.2/libmudflapth.a
dangling: /usr/lib/gcc/x86_64-redhat-linux/4.7.2/32/libmudflap.a -> ../../../i686-redhat-linux/4.7.2/libmudflap.a
dangling: /usr/lib/gcc/x86_64-redhat-linux/4.7.2/32/libsupc++.a -> ../../../i686-redhat-linux/4.7.2/libsupc++.a
dangling: /usr/lib/gcc/x86_64-redhat-linux/4.7.2/32/libquadmath.a -> ../../../i686-redhat-linux/4.7.2/libquadmath.a
dangling: /usr/lib/gcc/x86_64-redhat-linux/4.7.2/32/libgomp.so -> ../../../../libgomp.so.1.0.0
dangling: /usr/lib/gcc/x86_64-redhat-linux/4.7.2/32/libitm.a -> ../../../i686-redhat-linux/4.7.2/libitm.a
dangling: /usr/lib/gcc/x86_64-redhat-linux/4.7.2/32/libstdc++.so -> ../../../../libstdc++.so.6.0.17
[root@srv-rhsoft:~]$ rpm -q --file /usr/lib/gcc/x86_64-redhat-linux/4.7.2/32/libstdc++.a
gcc-c++-4.7.2-8.fc18.x86_64
[root@srv-rhsoft:~]$ rpm -q --file /usr/lib/gcc/x86_64-redhat-linux/4.7.2/32/libgcc_s.so
gcc-4.7.2-8.fc18.x86_64
Comment 1 Jakub Jelinek 2013-06-25 01:44:15 EDT
This is intentional, so that the package supports both -m64 and -m32 compilation, if you install the 32-bit rpms things work automatically, but that the 32-bit packages aren't required.
Comment 2 Harald Reindl 2013-06-25 06:03:49 EDT
intentionally broken?

why do not only the 32bit rpms create these symlinks?
yes, ifarch-constrcuts in SPEC-file exists
Comment 3 Jakub Jelinek 2013-06-25 06:07:26 EDT
Why do you use a word broken?  I don't see anything broken on the current state.
And, the 32-bit packages shouldn't be putting symlinks into the paths they shouldn't own (x86_64 specific paths).
Comment 4 Harald Reindl 2013-06-25 06:13:09 EDT
because the symlinks are broken?
this is how a symlink pointing to nowhere is called!

sorry, but i do *really* not understand why a 100% clean x86_64 setup is cluttered with symlinks pointing to nowhere somebody *could* find useable if he has 32bit packages installed 

i killed them multiple times because and thought they where from non-perfect dist-upgrades but after find them again i looked which package clutters my machine

Note You need to log in before you can comment on or make changes to this bug.