Bug 977590 - RFE: Very basic XML filled into new topics
RFE: Very basic XML filled into new topics
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 20:58 EDT by Misha H. Ali
Modified: 2013-07-16 20:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 20:41:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2013-06-24 20:58:08 EDT
It seems silly to add XML that we need for every topics by hand each time. Can we have something like the following filled in when a topic is created but commented out so that the "no content" message still shows up when rendered:

<!-- <section>
  <title>$TOPICTITLE</title>

</section>  -->

IMO, it would be faster and easier to uncomment this and start actually adding topic content than adding these global tags by hand.
Comment 1 Lee Newson 2013-06-24 21:02:20 EDT
This would currently not work with the csprocessor, as the topic is not empty.

You can also do this using the "section-basic" template, which can be accessed by using the CTRL+ALT+E pop-up menu.
Comment 2 Misha H. Ali 2013-06-24 21:08:05 EDT
Fair. I'm not privy to the reasoning behind the removal of the original concept, task and reference templates from new topics, but just in case this is possible, I've added an RFE for evaluation. 

IMO, if two tags are *always* going to be used, there should be a way to have it included in the new topics by default. At any rate, thanks for having a look at the RFEs and doing such a great job with the CCMS!
Comment 3 Lee Newson 2013-06-24 21:10:20 EDT
FWIW, those templates weren't removed but just how they are inserted is done differently, they are now accessed in the same way as above (via the CTRL+ALT+E menu)
Comment 4 Matthew Casperson 2013-07-01 00:59:22 EDT
Fixed in 201307011459.

I've updated the UI to default to a basic template when a new topic is created. We can probably expand on this when the metadata is cleaned up.

NOTE:
When QAing bug fixes, please make sure the build you are using is equal to or higher than the build identified above. Be aware that this fix may have only been applied in PressGang Next at this time, or it may not be currently applied in any production system, in which case it can only be verified at a later date.
Comment 5 Misha H. Ali 2013-07-04 00:49:08 EDT
Verified: New topic appears with section, title and para tags as a starter template.

Note You need to log in before you can comment on or make changes to this bug.