Bug 977596 - RFE: test mode/method for testing changing/external entities
RFE: test mode/method for testing changing/external entities
Status: CLOSED UPSTREAM
Product: Zanata
Classification: Community
Component: Maintainability (Show other bugs)
development
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michelle Kim
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 21:36 EDT by Damian Jansen
Modified: 2015-07-28 23:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-28 23:24:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2013-06-24 21:36:40 EDT
Description of problem:
Certain items cannot be tested automatedly due to dynamic features (e.g. Captcha) and external usage (e.g. email on registration)

Version-Release number of selected component (if applicable):
Dev (master)

There should be some concrete way of using Zanata in a test "mode" or with appropriate hooks, to allow such things as having a static Captcha or having emails sent to a specific address regardless of target.
Comment 2 Damian Jansen 2015-07-13 20:20:55 EDT
Reassigned to PM
Comment 3 Zanata Migrator 2015-07-28 23:24:35 EDT
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-247

Note You need to log in before you can comment on or make changes to this bug.