Bug 977754 - [WHQL][netkvm]NDISTest6.0 - [2 Machine]-2c Mini6RSSSendRecv failed because of a lots errors on win8 guests
[WHQL][netkvm]NDISTest6.0 - [2 Machine]-2c Mini6RSSSendRecv failed because of...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
: 968238 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 05:20 EDT by Min Deng
Modified: 2014-07-11 02:22 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 02:31:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2013-06-25 05:20:30 EDT
Description of problem:
NDISTest6.0 - [2 Machine]-2c Mini6RSSSendRecv failed as a lot of errors on win8 guests

Version-Release number of selected component (if applicable):
build 65
How reproducible:
6 times
Steps to Reproduce:
1.boot up guest with the CLI
  /usr/libexec/qemu-kvm -m 6G -smp 8,cores=8 -cpu cpu64-rhel6,+x2apic,+sep -usb -device usb-tablet -drive file=win8-32-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:22:47:15:23:42,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup0,downscript=no -device e1000,netdev=hostnet2,mac=00:32:58:14:3c:20,bus=pci.0,addr=0x6 -uuid 3b278c23-cb8b-4ba1-93af-a8c4f9a24037 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-32-64-nic1,server,nowait -mon chardev=111a,mode=readline -vnc :1 -vga cirrus -name win8-32-nic1-64-HCK -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio
2.submit the jobs to HCK
3.

Actual results:
The job failed due to a lots errors

Expected results:
The job can pass

Additional info:
Will upload HCK files later
Comment 2 Min Deng 2013-06-28 03:53:24 EDT
Created attachment 766439 [details]
hck-log
Comment 4 Dmitry Fleytman 2013-08-15 10:28:03 EDT
Hello Mike

This failure may be caused by absent CPU grouping configuration (see here: http://msdn.microsoft.com/en-us/library/windows/hardware/jj123528.aspx).

Following commands have to be executed on HCK client to configure CPU grouping properly:

bcdedit.exe /set groupsize 2
bcdedit.exe /set groupaware on
shutdown.exe -r -t 0 -f

I've tried this on Windows Server 2008 R2 and it helped.
Please, retest on all other relevant systems (Windows 7 32/64, Windows 8 32/64, Windows Server 2012).

NOTE: Please pay attention that there is another bug (BZ#960844) that leads to BSOD on support machine side during RSS tests. It looks like a tester bug that reproduces much more often with CPU grouping configured. While we are dealing with it please configure CPU grouping on test machine only and explicitly clear this configuration on support machine.

In order to clear CPU grouping configuration on support machine please run following commands:

bcdedit.exe /deletevalue groupsize
bcdedit.exe /deletevalue groupaware
shutdown.exe -r -t 0 -f

Thanks in advance,
Dmitry
Comment 5 lijin 2013-08-16 05:38:57 EDT
Hi Dmitry,
    
    We retest NDISTest6.0 - [2 Machine]-2c Mini6RSSSendRecv on win2k8R2 and win8-32 guest accoding to comment 4:

1.Job passed on win2k8R2 guest with configure CPU grouping on both nic1 and nic2;

2.Job still failed(guest still bsod with 7E code) on win8-32 guest even with configure CPU grouping on test machine only and explicitly clear this configuration on support machine.I will aso update it on BZ#960844.

Thanks a lot.
Comment 6 Dmitry Fleytman 2013-08-20 02:31:49 EDT
Closing the issue according to Comment #5
Comment 7 Dmitry Fleytman 2013-08-20 02:32:47 EDT
BSOD on support machine is tracked by BZ#960844.
Comment 8 Yan Vugenfirer 2013-08-26 09:22:21 EDT
*** Bug 968238 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.