Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 977812 - tune2fs failing to assign UUID to mounted partition
Summary: tune2fs failing to assign UUID to mounted partition
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: e2fsprogs
Version: 5.9
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Eric Sandeen
QA Contact: Eryu Guan
URL:
Whiteboard:
Depends On:
Blocks: 1049888
TreeView+ depends on / blocked
 
Reported: 2013-06-25 11:34 UTC by Vivek Satpute
Modified: 2014-02-05 18:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-05 18:18:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vivek Satpute 2013-06-25 11:34:56 UTC
Description of problem:
tune2fs failing to write UUID on given disk partition which is mounted.

Version-Release number of selected component (if applicable):
I am using e2fsprogs-1.39-35.el5

How reproducible:
Easily reproducible on my setup.

Steps to Reproduce:
1. Generate UUID using "uuidgen -t"
2. Assign newly generated UUID to rootdisk partition.
3. DO "sync" or "blockdev --flushbufs <disk-name>
4. Read UUID of same partition using "blkid", it gives old UUID.

Actual results:
UUID returned by blkid in above step-4 is not new one, its old one.

Expected results:
In above step-4, blkid should return newly assigned UUID.

Additional info:
Testlogs from my setup:
[root@punr710vm31 ~]# blkid /dev/sdai1
/dev/sdai1: LABEL="/" UUID="d27a5e3c-ae87-4748-9929-2461cbc637e2" TYPE="ext3"
[root@punr710vm31 ~]# uuidgen -t
710db828-dd84-11e2-9270-bc305be0077f
[root@punr710vm31 ~]# tune2fs -U 710db828-dd84-11e2-9270-bc305be0077f /dev/sdai1
tune2fs 1.39 (29-May-2006)
[root@punr710vm31 ~]# blkid /dev/sdai1
/dev/sdai1: LABEL="/" UUID="710db828-dd84-11e2-9270-bc305be0077f" TYPE="ext3"
[root@punr710vm31 ~]# sync
[root@punr710vm31 ~]# blkid /dev/sdai1
/dev/sdai1: LABEL="/" UUID="d27a5e3c-ae87-4748-9929-2461cbc637e2" TYPE="ext3"

[root@punr710vm31 ~]# cat /etc/issue
Red Hat Enterprise Linux Server release 5.9 (Tikanga)
Kernel \r on an \m

[root@punr710vm31 ~]# uname -a
Linux punr710vm31 2.6.18-348.el5 #1 SMP Wed Nov 28 21:22:00 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

[root@punr710vm31 ~]# rpm -qi e2fsprogs
Name        : e2fsprogs                    Relocations: (not relocatable)
Version     : 1.39                              Vendor: Red Hat, Inc.
Release     : 35.el5                        Build Date: Fri 13 Jul 2012 08:48:41 PM IST
Install Date: Wed 29 May 2013 04:43:04 PM IST      Build Host: x86-003.build.bos.redhat.com
Group       : System Environment/Base       Source RPM: e2fsprogs-1.39-35.el5.src.rpm
Size        : 1981648                          License: GPL
Signature   : DSA/SHA1, Fri 31 Aug 2012 11:54:34 AM IST, Key ID 5326810137017186
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://e2fsprogs.sourceforge.net/
Summary     : Utilities for managing the second and third extended (ext2/ext3) filesystems
Description :
The e2fsprogs package contains a number of utilities for creating,
checking, modifying, and correcting any inconsistencies in second
and third extended (ext2/ext3) filesystems. E2fsprogs contains
e2fsck (used to repair filesystem inconsistencies after an unclean
shutdown), mke2fs (used to initialize a partition to contain an
empty ext2 filesystem), debugfs (used to examine the internal
structure of a filesystem, to manually repair a corrupted
filesystem, or to create test cases for e2fsck), tune2fs (used to
modify filesystem parameters), and most of the other core ext2fs
filesystem utilities.

You should install the e2fsprogs package if you need to manage the
performance of an ext2 and/or ext3 filesystem.

Comment 1 Eric Sandeen 2013-06-26 16:37:56 UTC
Please raise this issue with your RHEL support channels so that they can help with prioritization and triage this issue.

Meanwhile, it seems to work fine here.

# blkid /dev/sda1
/dev/sda1: LABEL="/boot" UUID="c00f5300-e87a-42cd-9130-6d9cee6be607" TYPE="ext3" SEC_TYPE="ext2" 
# uuidgen -t
3e615a7a-de82-11e2-bad1-0017a43ff533

# tune2fs -U 3e615a7a-de82-11e2-bad1-0017a43ff533 /dev/sda1
tune2fs 1.39 (29-May-2006)
# blkid /dev/sda1
/dev/sda1: LABEL="/boot" UUID="3e615a7a-de82-11e2-bad1-0017a43ff533" TYPE="ext3" SEC_TYPE="ext2" 
# sync
# blkid /dev/sda1
/dev/sda1: LABEL="/boot" UUID="3e615a7a-de82-11e2-bad1-0017a43ff533" TYPE="ext3" SEC_TYPE="ext2" 
# sync
# blkid /dev/sda1
/dev/sda1: LABEL="/boot" UUID="3e615a7a-de82-11e2-bad1-0017a43ff533" TYPE="ext3" SEC_TYPE="ext2" 

# blkid -c /dev/null /dev/sda1
/dev/sda1: LABEL="/boot" UUID="3e615a7a-de82-11e2-bad1-0017a43ff533" TYPE="ext3" 


# uname -a
Linux $HOST 2.6.18-344.el5 #1 SMP Mon Oct 15 14:23:29 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux

# rpm -q e2fsprogs
e2fsprogs-1.39-35.el5

Anyway, please escalate through support.

Comment 2 Vivek Satpute 2013-06-27 08:59:44 UTC
Thanks Eric.
I am hitting this issue on one of my setup, and could not reproduce on other setups.

I would go via our support channel. Thanks again.

Comment 3 Zhang Kexin 2014-01-20 02:53:18 UTC
Hi Vivek,

Are you still hitting the issue now? Thanks.

Comment 4 Vivek Satpute 2014-02-05 17:54:17 UTC
I am not hitting the issue now. Please feel free to close this Bugzilla. Would re-open if hit it again.


Thanks and Regards,
Vivek Satpute

Comment 5 Eric Sandeen 2014-02-05 18:18:38 UTC
Ok, thanks for the followup.


Note You need to log in before you can comment on or make changes to this bug.