Bug 977823 - A user with only "Delete Content View Definitions" permissions unable to delete content views
A user with only "Delete Content View Definitions" permissions unable to dele...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Partha Aji
Kedar Bidarkar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 08:19 EDT by Kedar Bidarkar
Modified: 2014-04-28 10:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-28 10:11:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kedar Bidarkar 2013-06-25 08:19:38 EDT
Description of problem:
A user with only "Delete Content View Definitions" permissions unable to delete content views

Version-Release number of selected component (if applicable):


How reproducible:
When logged in with a user, which has only the permission for "Delete Content view Definitions" under the roles.

Steps to Reproduce:
1. Create a role with permission "Delete Content View Definitions"
2. create a new user
3. Add the above role to the above user created
4. Login with the user, navigate to the cv to find no Remove link.
  
Actual results:
No remove link, until we add "Administer Content view Definitions" also to the role

Expected results:
The Remove link  should exist, even with just "Administer Content View Definitions"



Additional info:

Also the only way we could Delete a content view is when we add "Administer Content View Definitions", is that this is some kind of a Super Privilege, I think this is similar to Create CV's.
Comment 1 RHEL Product and Program Management 2013-09-17 00:25:05 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 Partha Aji 2013-09-19 17:04:29 EDT
Should be fixed when https://github.com/Katello/katello/pull/3009 gets merged to master
Comment 7 Mike McCune 2013-10-17 17:01:44 EDT
Moving this to be tested during MDP3, not critical for MDP2 success story
Comment 8 Kedar Bidarkar 2014-04-28 10:11:30 EDT
The UI functionality has changed, we no longer have the functionality to delete content views and hence permission also would be obsolete.

Note You need to log in before you can comment on or make changes to this bug.