Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 977836 - --ticket-number option ignored
Summary: --ticket-number option ignored
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector
Version: 3.2.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: 3.3.0
Assignee: Kiril Nesenko
QA Contact: sefi litmanovich
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-25 12:55 UTC by Julio Entrena Perez
Modified: 2018-12-05 16:08 UTC (History)
9 users (show)

Fixed In Version: rhevm-log-collector-3.3.0-1.el6ev
Doc Type: Bug Fix
Doc Text:
rhevm-log-collector ignores the "--ticket-number" option, which should create a tarball with a ticket number. This has now been fixed, so specifying --ticket-number option will generate a correct tarball name.
Clone Of:
Environment:
Last Closed: 2014-01-21 16:59:37 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 408043 0 None None None Never
Red Hat Product Errata RHBA-2014:0039 0 normal SHIPPED_LIVE rhevm-log-collector bug fix and enhancement update 2014-01-21 21:52:46 UTC
oVirt gerrit 18388 0 None None None Never

Description Julio Entrena Perez 2013-06-25 12:55:22 UTC
Description of problem:
rhevm-log-collector ignores "--ticket-number=" option.
Resulting tarball filename does not include specified case number.

Version-Release number of selected component (if applicable):
rhevm-log-collector-3.2.2-3.el6ev

How reproducible:
Always.

Steps to Reproduce:
1. Run "rhevm-log-collector --ticket-number=00123456"
2. Observe resulting tarball filename.

Actual results:
Tarball filename does not include specified ticket number:
sosreport-LogCollector-20130625135145.tar.xz

Expected results:
Tarball filename includes specified ticket number:
sosreport-LogCollector-00123456-20130625135145.tar.xz

Additional info:
# rhevm-log-collector --help | grep ticket
  --ticket-number=TICKET
                        ticket number to pass with the sosreport

This is very relevant for customer since they rely on the ticket number being present in the filename for automated uploads of logcollectors to us.

Comment 2 sefi litmanovich 2013-09-23 15:50:14 UTC
Verified on rhevm 3.3 is15.
rhevm-log-collector-3.3.0-1.el6ev

Comment 3 Charlie 2013-11-28 01:16:37 UTC
This bug is currently attached to errata RHBA-2013:15255. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.

Comment 4 errata-xmlrpc 2014-01-21 16:59:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0039.html


Note You need to log in before you can comment on or make changes to this bug.