Bug 977883 - removing default datacenter doesn't remove default cluster
removing default datacenter doesn't remove default cluster
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mooli Tayer
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 10:15 EDT by Ohad Basan
Modified: 2016-02-10 14:33 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-10 09:55:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ohad Basan 2013-06-25 10:15:38 EDT
Description of problem:

When removing the default datacenter the default cluster doesn't get removed.
That could cause a host to get "stuck" on the default cluster without the ability to move it to another cluster.
on the UI it shows default cluster but when clicking edit it shows another active cluster.
Comment 2 Itamar Heim 2013-06-26 07:16:30 EDT
omer - didn't we use to block removing default DC due to blank template?
Comment 3 Omer Frenkel 2013-06-30 09:55:33 EDT
(In reply to Itamar Heim from comment #2)
> omer - didn't we use to block removing default DC due to blank template?

no, only remove of default cluster is blocked.
it is valid to have no dc in the system, because creating vms depends on that.
default cluster is needed because cluster is mandatory field of template.

there should not be a problem changing the cluster for such host (that is in a cluster with no dc), the reported problem here sounds like a UI problem.

Ohad, can you try to change the cluster using rest api?
Comment 4 Mooli Tayer 2013-07-10 09:55:18 EDT
to sum up the above:
1. Removing the default cluster should not be possible.
2. Moving a host from the default cluster to a different cluster should be possible.

Tried to do 2 and It worked. also contacted Ohad and he said that it did not reproduce for him too. Closing...

Note You need to log in before you can comment on or make changes to this bug.