Bug 977913 - ExceptionMapper waits for timeout of AsynchronousResponse
ExceptionMapper waits for timeout of AsynchronousResponse
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: RESTEasy (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity medium
: ER3
: EAP 6.2.0
Assigned To: Weinan Li
Petr Sakař
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 11:05 EDT by Travis Rogers
Modified: 2014-06-18 03:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:23:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RESTEASY-736.zip (9.22 KB, application/zip)
2013-10-16 06:00 EDT, Petr Sakař
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker RESTEASY-721 Major Closed ExceptionMapper waits for timeout of AsynchronousResponse 2014-04-12 19:42:32 EDT

  None (edit)
Description Travis Rogers 2013-06-25 11:05:18 EDT
When using AsynchronousResponse the client needs to wait for the specified timeout in case the ExceptionMapper is triggered. This is unexpected behaviour since the exception should be returned immediately. (In fact this is done, but the client keeps waiting for the server to close the connection).
Comment 3 JBoss JIRA Server 2013-07-15 17:14:06 EDT
Bill Burke <bill@jboss.org> updated the status of jira RESTEASY-721 to Closed
Comment 4 Weinan Li 2013-09-23 06:21:15 EDT
This has been fixed in 2.3.7.Final
Comment 8 Petr Sakař 2013-10-16 06:00:09 EDT
Created attachment 812849 [details]
RESTEASY-736.zip

project to verify bug is fixed.
to see test failure run
  mvn clean test
to verify run
  mvn clean test -Dresteasy.version=2.3.7.Final-redhat-2

Note You need to log in before you can comment on or make changes to this bug.