Bug 978014 - obsolete upstart for upgrade from RHEL 6
obsolete upstart for upgrade from RHEL 6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: systemd-maint
Petr Sklenar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 15:42 EDT by David Shea
Modified: 2014-06-17 20:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: systemd-206-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:38:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Shea 2013-06-25 15:42:44 EDT
Description of problem:
systemd replaces upstart in RHEL 7, but there is not currently metadata in the systemd package to obsolete upstart.

The systemd spec file for Fedora 19 includes the line "Obsoletes: upstart < 1.2-7" but this is not present in the RHEL 7 version. The obsolete is still relevant for RHEL 6 to 7 upgrades.

Version-Release number of selected component (if applicable):
systemd-204-8.el7.x86_64
Comment 2 Paul W. Frields 2013-09-17 15:21:53 EDT
Hi systemd team, can one of you make the required change in the rhel-7.0 branch to systemd.spec?  Thanks.

Also, unfortunately since the dist-git policy for RHEL 7.0 now requires 'rhel-7.0.0+' (3-ACK'd bug), you'll need to add devel_ack+ and get a qa_ack+ to push the change referencing this bug.
Comment 3 Harald Hoyer 2013-09-17 15:27:44 EDT
* Thu Aug 22 2013 Harald Hoyer <harald@redhat.com> 206-5
- obsolete upstart
Resolves: rhbz#978014
- obsolete hal
Resolves: rhbz#975589
Comment 11 Ludek Smid 2014-06-13 07:38:47 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.