Bug 978037 - [abrt] smolt-1.4.3-6.fc17: smolt.py:927:getProfile:TypeError: decoding Unicode is not supported
[abrt] smolt-1.4.3-6.fc17: smolt.py:927:getProfile:TypeError: decoding Unicod...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
abrt_hash:a940f42e52f0348aee02339808b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 16:57 EDT by Brad Hubbard
Modified: 2014-05-17 20:21 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-06 05:22:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1021 bytes, text/plain)
2013-06-25 16:57 EDT, Brad Hubbard
no flags Details
File: core_backtrace (264 bytes, text/plain)
2013-06-25 16:57 EDT, Brad Hubbard
no flags Details
File: environ (154 bytes, text/plain)
2013-06-25 16:57 EDT, Brad Hubbard
no flags Details

  None (edit)
Description Brad Hubbard 2013-06-25 16:57:15 EDT
Version-Release number of selected component:
smolt-1.4.3-6.fc17

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/bin/smoltSendProfile -c
executable:     /usr/bin/smoltSendProfile
kernel:         3.9.6-301.6.fc19.x86_64
runlevel:       N 5
uid:            999

Truncated backtrace:
smolt.py:927:getProfile:TypeError: decoding Unicode is not supported

Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 281, in <module>
    batch=opts.checkin)
  File "/usr/share/smolt/client/smolt.py", line 773, in send
    '.rst':'\n'.join(map(to_ascii, self.getProfile())),
  File "/usr/share/smolt/client/smolt.py", line 927, in getProfile
    printBuffer.append('%s: %s' % (unicode(label, 'utf-8'), data))
TypeError: decoding Unicode is not supported

Local variables in innermost frame:
printBuffer: [u'# This is a Smolt report shown within your default pager.', u'# Below you can see what data you will submit to the server.', u'# To get back to Smolt exit the pager (try hitting "q").', '#', u'# NOTE:  Editing this file does not change the data submitted.', '', '', u'General', '=================================', u'UUID: 8808b2e5-cf0e-4a2b-a7af-792f29fff2bb']
self: <smolt._Hardware instance at 0x5b115f0>
data: 'Fedora release 19 (Schr\xc3\xb6dinger\xe2\x80\x99s Cat)'
label: u'OS'

Potential duplicate: bug 802113
Comment 1 Brad Hubbard 2013-06-25 16:57:19 EDT
Created attachment 765286 [details]
File: backtrace
Comment 2 Brad Hubbard 2013-06-25 16:57:22 EDT
Created attachment 765287 [details]
File: core_backtrace
Comment 3 Brad Hubbard 2013-06-25 16:57:25 EDT
Created attachment 765288 [details]
File: environ
Comment 4 Christopher Meng 2013-08-30 09:16:10 EDT
Isn't Smolt already retired?
Comment 5 Terry A. Hurlbut 2013-09-06 22:28:50 EDT
Description of problem:
Had a browser and an e-mail client open, plus a text editor. That's all.

Version-Release number of selected component:
smolt-1.4.3-6.fc17

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python /usr/bin/smoltSendProfile -c
executable:     /usr/bin/smoltSendProfile
kernel:         3.10.10-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            999

Truncated backtrace:
smolt.py:927:getProfile:TypeError: decoding Unicode is not supported

Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 281, in <module>
    batch=opts.checkin)
  File "/usr/share/smolt/client/smolt.py", line 773, in send
    '.rst':'\n'.join(map(to_ascii, self.getProfile())),
  File "/usr/share/smolt/client/smolt.py", line 927, in getProfile
    printBuffer.append('%s: %s' % (unicode(label, 'utf-8'), data))
TypeError: decoding Unicode is not supported

Local variables in innermost frame:
printBuffer: [u'# This is a Smolt report shown within your default pager.', u'# Below you can see what data you will submit to the server.', u'# To get back to Smolt exit the pager (try hitting "q").', '#', u'# NOTE:  Editing this file does not change the data submitted.', '', '', u'General', '=================================', u'UUID: c32ec91e-6c41-4d58-8b9e-46edf8e8627a']
self: <smolt._Hardware instance at 0x4ba8908>
data: 'Fedora release 19 (Schr\xc3\xb6dinger\xe2\x80\x99s Cat)'
label: u'OS'
Comment 6 Michael Schwendt 2013-09-07 05:54:11 EDT
> smolt-1.4.3-6.fc17

Erase it. It's been abandoned.
https://admin.fedoraproject.org/pkgdb/acls/name/smolt

Also look into tracking down and erasing other deprecated/retired packages. "yum -y update ; yum list extras" helps with that (and "package-cleanup --orphans" lists them, too).
Comment 7 Jacek Radzikowski 2013-09-07 12:06:07 EDT
Shouldn't updater erase it? I updated my system from F17
Comment 8 Michael Schwendt 2013-09-07 12:51:46 EDT
No, you need to decide whether you still want/need it.

The installer/updater only removes packages, which are obsoleted/replaced by some other package. There hasn't been any general garbage collection method so far.
Comment 9 Jacek Radzikowski 2013-09-07 14:18:33 EDT
Since it is obsolete and not used any more, I just removed the package and all dependences. 

Is there a way to identify all obsolete packages left behind by the upgrader?
Comment 10 Michael Schwendt 2013-09-07 14:25:44 EDT
yes, see bottom of comment 6
Comment 11 Jacek Radzikowski 2013-09-07 14:29:11 EDT
Thanks. I rushed to erase smolt and missed the rest of the comment.
Comment 12 Christopher Meng 2013-12-06 05:22:20 EST
Smolt is no longer served in Fedora.

Note You need to log in before you can comment on or make changes to this bug.