Bug 978067 - Multilib version problems found while installing freeipa-client
Multilib version problems found while installing freeipa-client
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jakub Hrozek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 18:18 EDT by Dean Hunter
Modified: 2013-07-02 11:45 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 11:45:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Hunter 2013-06-25 18:18:30 EDT
Description of problem:

yum install --assumeyes freeipa-client fails with multilib version problems.


Version-Release number of selected component (if applicable):

freeipa-client-3.2.1-1.fc19.x86_64


How reproducible: Consistent


Steps to Reproduce:

1. Build a new Fedora 19 VM with the updates-testing repository disabled
2. Login through console
3. su -
4. yum install --assumeyes freeipa-client


Actual results:

Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for libipa_hbac which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libipa_hbac of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libipa_hbac.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of libipa_hbac installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of libipa_hbac installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: libipa_hbac-1.10.0-11.fc19.beta2.i686 != libipa_hbac-1.10.0-12.fc19.beta2.x86_64
Error: Protected multilib versions: nss-softokn-freebl-3.14.3-1.fc19.i686 != nss-softokn-freebl-3.15-3.fc19.x86_64
Error: Protected multilib versions: krb5-libs-1.11.3-1.fc19.i686 != krb5-libs-1.11.3-2.fc19.x86_64


Expected results:

Successful install


Additional info:
Comment 1 Martin Kosek 2013-06-26 03:03:12 EDT
Jakub, can you please advise? libipa_hbac is from SSSD so I am adding you to CC in case this rings a bell for you.

Speaking of related FreeIPA requires, I found following in our spec:

Requires: sssd >= 1.8.0
...
Requires: libipa_hbac-python
Comment 2 Jakub Hrozek 2013-06-26 04:41:43 EDT
What architecture is the system? Does it have any of the packages yum complains about installed already?

It doesn't really have much sense to have libipa_hbac installed with multiple architectures. There are only two consumers -- libipa_hbac-python used by IPA and the SSSD deamon. The former is noarch and the latter is base arch only.
Comment 3 Alexander Bokovoy 2013-06-26 05:25:46 EDT
I've encountered the same issue yesterday when tried to use SSSD from freeipa-devel repo. It has SSSD git checkout marked as 1.9.95 and my attempt to downgrade from F19's 1.10 version failed with exactly the same problem on x86_64.

I had to remove all SSSD related packages manually (rpm -e --nodeps) and then install with 'yum install {sssd-{ldap,client,common,krb5,proxy,ipa,debuginfo,ad,krb5-common},sssd,libsss_nss_idmap,libsss_idmap,libipa_hbac{,-python}}-1.9.95}
Comment 4 Dean Hunter 2013-06-26 15:28:52 EDT
What architecture is the system?  x86_64

Does it have any of the packages yum complains about installed already?

  libipa_hbac-1.10.0-12.fc19.beta2.x86_64
  nss-softokn-freebl-3.15-3.fc19.x86_64
  krb5-libs-1.11.3-2.fc19.x86_64

Following the steps in the error report:

  yum install --assumeyes --exclude libipa_hbac.otherarch freeipa-client

performs a successful install.
Comment 5 Jakub Hrozek 2013-06-26 17:40:44 EDT
OK, seems like a bug with how we handle the %{isa} extension perhaps. I haven't reproduced the issue myself yet, sorry, I've been busy with some other pending 1.10 patches. But given that Alexander confirmed the problem too, I'm fairly confident we can reproduce in-house.

Thank you for the testing.
Comment 6 Martin Kosek 2013-06-27 02:55:36 EDT
Thanks, it seems we can have some clue where the issue resides. Moving to sssd component.
Comment 7 Lukas Slebodnik 2013-06-27 04:05:57 EDT
Problem isn't in sssd packaging.

Next command works:
yum install krb5-workstation --enablerepo=updates-testing

But without updates-testing, yum will fail with the same error like in bug description.

yum install krb5-workstation
#snip 
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for krb5-libs which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of krb5-libs of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude krb5-libs.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of krb5-libs installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of krb5-libs installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: krb5-libs-1.11.3-1.fc19.i686 != krb5-libs-1.11.3-2.fc19.x86_64
Comment 8 Jakub Hrozek 2013-06-30 15:08:56 EDT
Hi,

Thanks a lot for the testing Lukas. I believe the problem was that krb5 was pushed from updates-testing to stable before sssd (or the other way around).

I believe it should be fixed now. Dean, does the problem still persist? I wasn't able to reproduce it either with or without updates-testing.

If not, then feel free to close the bug (I'm on vacation next week so I won't respond, sorry.)
Comment 9 Dean Hunter 2013-07-02 11:45:54 EDT
Thank you.  I have verified that this problem has been resolved.

Note You need to log in before you can comment on or make changes to this bug.