Bug 978135 - Message.setJMSMessageID() error message is incorrect
Message.setJMSMessageID() error message is incorrect
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-java (Show other bugs)
2.3
Unspecified Unspecified
low Severity low
: 3.0
: ---
Assigned To: Rajith Attapattu
Michal Toth
:
Depends On:
Blocks: 978279
  Show dependency treegraph
 
Reported: 2013-06-25 23:50 EDT by Mike Cressman
Modified: 2014-09-24 11:08 EDT (History)
5 users (show)

See Also:
Fixed In Version: qpid-java-0.22-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 978279 (view as bug list)
Environment:
Last Closed: 2014-09-24 11:08:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1296 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.0 Release 2014-09-24 15:00:06 EDT

  None (edit)
Description Mike Cressman 2013-06-25 23:50:34 EDT
Description of problem:
When Message.setJMSMessage is called with input "myString", the error message states: 

javax.jms.JMSException: MessageId 'myId' is not of the correct format, it must be ID: followed by a UUID
	at org.apache.qpid.client.message.AMQMessageDelegate_0_10.setJMSMessageID(AMQMessageDelegate_0_10.java:197)
	at org.apache.qpid.client.message.AbstractJMSMessage.setJMSMessageID(AbstractJMSMessage.java:63)
...


In fact, the message must be "ID:<anyString>"

The second part of the string can be any string, as of MRG-M 2.3.3 (see Bug 952750)

Version-Release number of selected component (if applicable):
qpid-java-0.18-8 (MRG-M 2.3.3)

How reproducible:
100%

Steps to Reproduce:
1. call setJMSMessageID() using any invalid string (such as one that does not start with "ID:")
2.
3.

Actual results:
Incorrect error message is generated

Expected results:
Message should be something like:
MessageId 'myId' is not of the correct format, it must be of the form "ID:<anyString>"

Additional info:
Comment 1 Rajith Attapattu 2013-07-23 10:37:57 EDT
Posted a fix upstream at http://svn.apache.org/r1506068
Comment 2 Michal Toth 2013-08-27 05:28:36 EDT
Bug fix tested on both RHEL6 architectures.
Error message works as expected.

Tested using
qpid-cpp-server-0.22-11.el6
qpid-java-client-0.22-5.el6
Comment 5 errata-xmlrpc 2014-09-24 11:08:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html

Note You need to log in before you can comment on or make changes to this bug.