Bug 978184 - [Fed] Installation fails when we select auto partition with BTRFS
[Fed] Installation fails when we select auto partition with BTRFS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
s390x All
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 01:50 EDT by IBM Bug Proxy
Modified: 2014-02-27 17:49 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-27 17:48:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (13.19 KB, application/octet-stream)
2013-06-26 01:51 EDT, IBM Bug Proxy
no flags Details
program log (37.43 KB, application/octet-stream)
2013-06-26 01:51 EDT, IBM Bug Proxy
no flags Details
syslog (51.93 KB, application/octet-stream)
2013-06-26 01:51 EDT, IBM Bug Proxy
no flags Details
storage log (173.52 KB, application/octet-stream)
2013-06-26 01:51 EDT, IBM Bug Proxy
no flags Details
zvm log (8.01 KB, text/plain)
2013-06-26 01:51 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 95209 None None None Never

  None (edit)
Description IBM Bug Proxy 2013-06-26 01:50:45 EDT
Problem Description
-------------------------------------
The issue is observed while installing F19 on dasd

1. Start the installation 
2. Provide  all the config parameters via params file
3. Go for vnc mode of installation
4. Select  two disk 
5. Go for auto partition with BTRFS Partition scheme 

Actual - Installation fails on reboot enters emergency mode 

Please find the attached logs 

    1.858523] Process plymouth (pid: 563, task: 000000003b1948c0, ksp: 00000000
397f3ac8)                                                                       
[    1.858524] User PSW : 0705000180000000 00000040105a9ba2 (0x40105a9ba2)      
[    1.858527]            R:0 T:1 IO:1 EX:1 Key:0 M:1 W:0 P:1 AS:0 CC:0 PM:0 EA:
3                                                                               
User GPRS: 0000000000000000 00000040105ab130 0000000000000000 00000000a1d06f30  
[    1.858530]            00000040105a9ba2 00000000a1d06f40 000003ffffba2e70 000
003ffffba32a0                                                                   
[    1.858531]            0000000080003088 0000000092e22790 0000000092e22f40 000
003ffffba32b8                                                                   
[    1.858532]            000003ffffba3070 00000000800073fa 00000040105a9ba2 000
003ffffba2b98                                                                   
[    1.858538] User Code: 00000040105a9b94: a784002b            brc     8,40105a
9bea                                                                            
           00000040105a9b98: 41202010           la      %r2,16(%r2)             
          #00000040105a9b9c: c0e5fffff90a       brasl   %r14,40105a8db0         
          >00000040105a9ba2: e3b020080004       lg      %r11,8(%r2)             
           00000040105a9ba8: b904002d           lgr     %r2,%r13                
           00000040105a9bac: c0e5ffffe17a       brasl   %r14,40105a5ea0         
           00000040105a9bb2: c0100000848f       larl    %r1,40105ba4d0          
           00000040105a9bb8: b9040032           lgr     %r3,%r2                 
[    1.858551] Last Breaking-Event-Address:      

[    1.858552]  [<00000040105a8e72>] 0x40105a8e72                               
//lib/dracut/hooks/emergency/50-plymouth-emergency.sh: line 4:   563 Segmentatio
n fault      plymouth --hide-splash 2> /dev/null                                
                                                                                
Generating "/run/initramfs/sosreport.txt"                                       
                                                                                
                                                                                
Entering emergency mode. Exit the shell to continue.                            
Type "journalctl" to view system logs.                                          
You might want to save "/run/initramfs/sosreport.txt" to a USB stick or /boot   
after mounting them and attach it to a bug report.                              
                                                                                
                                                                                
:/#
Comment 1 IBM Bug Proxy 2013-06-26 01:51:00 EDT
Created attachment 765394 [details]
anaconda log
Comment 2 IBM Bug Proxy 2013-06-26 01:51:14 EDT
Created attachment 765395 [details]
program log
Comment 3 IBM Bug Proxy 2013-06-26 01:51:28 EDT
Created attachment 765396 [details]
syslog
Comment 4 IBM Bug Proxy 2013-06-26 01:51:41 EDT
Created attachment 765397 [details]
storage log
Comment 5 IBM Bug Proxy 2013-06-26 01:51:54 EDT
Created attachment 765398 [details]
zvm log
Comment 6 Jan Stodola 2013-06-26 08:23:06 EDT
Reproduced, including the segmentation fault error.

There seems to be two issues:
1) installed system fails to boot on s390x if rootfs is on Btrfs - this is reported as bug 874622. After adding "rootflags=subvol=root" to the kernel command line, system boots fine despite the aborted processes.

2) The aborted process itself is reported as bug 972714.

Is there any other issue to keep this bug open?
Comment 7 IBM Bug Proxy 2014-02-27 11:03:30 EST
------- Comment From thorsten.diehl@de.ibm.com 2014-02-27 15:55 EDT-------
fixed in RHEL7 snap8.
worked with rd.dasd=0.0.abc2 rd.dasd=0.0.abc3
and also with rd.dasd=0.0.abc2 rd.dasd=0.0.abc1

Can be closed, if somebody can confirm that it found it's way into Fedora, too.
Comment 8 David Shea 2014-02-27 17:49:54 EST
Confirmed the change for bug 874622 is on master as commit b3b60cd5

Note You need to log in before you can comment on or make changes to this bug.