Bug 97820 - printer sharing over an interface is broken
printer sharing over an interface is broken
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-22 06:00 EDT by Gerald Teschl
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version: 0.6.64-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-25 07:09:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
quotes.patch (1.59 KB, patch)
2003-06-23 05:39 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Gerald Teschl 2003-06-22 06:00:34 EDT
Description of problem:
I just wanted to share a printer for all computers on eth1, but
it did not work

Investigation of cupsd.conf showed a line

Listen "192.168.0.1":631

and changing this to

Listen 192.168.0.1:631

made cupsd happy.

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.57-1
Comment 1 Tim Waugh 2003-06-23 05:38:47 EDT
Fixed package will be 0.6.63-1.
Comment 2 Tim Waugh 2003-06-23 05:39:17 EDT
Created attachment 92546 [details]
quotes.patch

In the mean time, please try this patch.
Comment 3 Gerald Teschl 2003-06-24 14:33:25 EDT
Nope, not fixed in redhat-config-printer-0.6.63-1.i386.rpm.

Now it writes:

Listen 127.0.0.1:631
Listen 192.168.0.1"
:631

Oviously it only strips the first quote, but not the second one and not
the newline. Awaiting the next fix;-)
Comment 4 Gerald Teschl 2003-06-24 14:38:24 EDT
Just noticed two more things:

1) There is another line containing only ":631". In particluar the end
of the file looks like


-------------------------------------------
#
# End of "$Id: cupsd.conf.in,v 1.8 2002/12/13 16:23:54 mike Exp $".
#
:631
<Location /printers/lp>
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
AuthType None
Allow from @IF(eth1)
</Location>
<Location />
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
</Location>
Browsing On
BrowseProtocols cups
BrowseOrder Deny,Allow
BrowseAllow from @LOCAL
BrowseAddress 255.255.255.255
Listen 127.0.0.1:631
Listen 192.168.0.1"
:631

------------------------

2) There is no warning present that this file is generated by printconf
and manual changes will be lost.
Comment 5 Tim Waugh 2003-06-25 07:09:45 EDT
Oops, forgot there would be a newline in the string.  Fixed in
redhat-config-printer-0.6.64-1, which should appear in rawhide later today.
Comment 6 Tim Waugh 2003-07-07 12:36:37 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-125.html

Note You need to log in before you can comment on or make changes to this bug.