Bug 978207 - After Edit VM options and add options to VM custom options in RHEM admin portal,it does not display correctly
After Edit VM options and add options to VM custom options in RHEM admin port...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-config (Show other bugs)
3.1.0
All Linux
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Shahar Havivi
Pavel Novotny
virt
:
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-06-26 02:23 EDT by Hao.Xiaolong
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 02:00:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hao.Xiaolong 2013-06-26 02:23:21 EDT
Description of problem:
After Edit VM options and add options to VM custom options in RHEM admin portal,it does not display correctly

Version-Release number of selected component (if applicable):
RHEVM 3.1

How reproducible:
always

Steps to Reproduce:
1. run following command to define “User define VMProperties”
rhevm-config -s UserDefinedVMProperties='qemu_cmdline=^.*$'

2.service ovirt-engine restart

3.In RHEVM admin portal:

Edit VM options ,select “qemu_cmdline= ”and put following options in whole string including the bracketsto the text box 
["-global","qxl-vga.debug=5","-global","qxl-vga.guestdebug=1"]

4.press OK to save this value.

Actual results:
Only characters "["-global","qxl-vga.debug" left, the other character disappeared.

Expected results:

the value should be "["-global","qxl-vga.debug=5","-global","qxl-vga.guestdebug=1"]
"

Additional info:
Comment 1 Shahar Havivi 2013-08-12 08:13:55 EDT
cannot reproduce on:
1. latest upstream
2. rhevm-3.2.1-0.39.el6ev.noarch
Comment 2 Shahar Havivi 2013-08-12 08:17:05 EDT
Can you please try that on the latest 3.2 and see if you can reproduce it?
(it should be fix)
Comment 3 Hao.Xiaolong 2013-08-20 01:49:41 EDT
already verified , not able to reproduce on the latest 3.2. seems fixed on 3.2

Note You need to log in before you can comment on or make changes to this bug.