Bug 97821 - crash: evolution does not like aspell-en package
crash: evolution does not like aspell-en package
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: evolution (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-22 09:09 EDT by Toni Willberg
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-24 20:00:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toni Willberg 2003-06-22 09:09:39 EDT
Start evolution from shell, try to forward some mail:

$ evolution
Unhandled Error: The file "/usr/lib/aspell/en-only.rws" is not in the proper
format. Wrong Soundslike

I've seen this earlier with aspell-es package too.


Perhaps those packages are really broken, and not something with Evo, can't be sure.

Version-Release number of selected component (if applicable):
evolution-1.4.0-2
aspell-0.50.3-12
aspell-en-0.51-5

How reproducible:
Always
Comment 1 Toni Willberg 2003-06-22 09:21:23 EDT
The problem seemed to go away by downgrading to previous aspell-en package.

Anyway, evo should not crash like that.
Comment 2 Kaj J. Niemi 2003-06-22 15:52:00 EDT
I filed bug 45248 on ximian's bugzilla regarding this. :)
Comment 3 Alexander Farley 2003-06-23 14:17:07 EDT
I received the same error, except for replying to and sending new emails. The
error that I got also referred to bonobo.c :

(evolution:11118): Bonobo-CRITICAL **: file bonobo-ui-util.c: line 182
(bonobo_ui_util_xml_to_pixbuf): assertion `xml != NULL' failed
Comment 4 Alexander Farley 2003-06-23 14:17:49 EDT
I received the same error, except for replying to and sending new emails. The
error that I got also referred to bonobo.c :

(evolution:11118): Bonobo-CRITICAL **: file bonobo-ui-util.c: line 182
(bonobo_ui_util_xml_to_pixbuf): assertion `xml != NULL' failed
Comment 5 Jeremy Katz 2003-06-23 18:58:45 EDT
Unfortunately, aspell does an abort() when this happens, so there's not much
evolution can do :/ 

The root cause is that the dictionary files are not arch-independent anymore --
Adrian is rebuilding them as non-noarch packages.
Comment 6 Toni Willberg 2003-07-23 06:55:55 EDT
Should this be reported as a aspell bug then? :)
Comment 7 Alexander Farley 2003-07-23 08:11:02 EDT
This problem seems to have been fixed when aspell-en was recompiled. There does
not seem to be a problem with evolution-1.4.3-3 and aspell-en-0.51-6.

Note You need to log in before you can comment on or make changes to this bug.