This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 978229 - Invalid pom files for s-ramp examples
Invalid pom files for s-ramp examples
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: DR7
: 6.0.0
Assigned To: Nick Cross
Stefan Bunciak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 02:51 EDT by Jiri Pechanec
Modified: 2014-02-06 10:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Some examples were not working as expected. When attempting to execute S-Ramp examples, an error would occur. This was due to invalid pom.xml files. This has been patched in the current version. The examples execute without errors.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Pechanec 2013-06-26 02:51:05 EDT
S-Ramp examples have s set of invalid pom.xml files
 - they refer to wrong switchyard version - 0.8.0.Final
 - there is a multitude of pom.xml files that contains definition of of repositories that overrides settings.xml and prevents using delivered offline repos
Comment 1 Jiri Pechanec 2013-06-26 02:51:57 EDT
In DR6
Comment 2 Jiri Pechanec 2013-06-26 10:01:10 EDT
I tried to modify the POMs to use 1.0 alpha and I got NPE in tests
java.lang.NullPointerException
        at org.switchyard.component.soap.util.WSDLUtil.getFeature(WSDLUtil.java:672)
        at org.switchyard.component.soap.InboundHandler.start(InboundHandler.java:116)
        at org.switchyard.deploy.internal.Deployment.deployServiceBindings(Deployment.java:520)
        at org.switchyard.deploy.internal.Deployment.start(Deployment.java:141)
        at org.switchyard.test.SwitchYardTestKit.deploy(SwitchYardTestKit.java:278)
        at org.switchyard.test.SwitchYardTestKit.start(SwitchYardTestKit.java:181)
        at org.switchyard.test.SwitchYardRunner.createTest(SwitchYardRunner.java:65)
        at org.junit.runners.BlockJUnit4ClassRunner$1.runReflectiveCall(BlockJUnit4ClassRunner.java:258)
        at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
        at org.junit.runners.BlockJUnit4ClassRunner.methodBlock(BlockJUnit4ClassRunner.java:255)
        at org.junit.runners.BlockJUnit4ClassRunner.runNotIgnored(BlockJUnit4ClassRunner.java:79)
        at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:71)
        at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:49)
        at org.junit.runners.ParentRunner$3.run(ParentRunner.java:193)
        at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:52)
        at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:191)
        at org.junit.runners.ParentRunner.access$000(ParentRunner.java:42)
        at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:184)
        at org.junit.runners.ParentRunner.run(ParentRunner.java:236)
        at org.switchyard.test.SwitchYardRunner.run(SwitchYardRunner.java:90)
        at org.apache.maven.surefire.junit4.JUnit4TestSet.execute(JUnit4TestSet.java:53)
        at org.apache.maven.surefire.junit4.JUnit4Provider.executeTestSet(JUnit4Provider.java:123)
        at org.apache.maven.surefire.junit4.JUnit4Provider.invoke(JUnit4Provider.java:104)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.apache.maven.surefire.util.ReflectionUtils.invokeMethodWithArray(ReflectionUtils.java:164)
        at org.apache.maven.surefire.booter.ProviderFactory$ProviderProxy.invoke(ProviderFactory.java:110)
        at org.apache.maven.surefire.booter.SurefireStarter.invokeProvider(SurefireStarter.java:175)
        at org.apache.maven.surefire.booter.SurefireStarter.runSuitesInProcessWhenForked(SurefireStarter.java:107)
        at org.apache.maven.surefire.booter.ForkedBooter.main(ForkedBooter.java:68)
Comment 3 Eric Wittmann 2013-06-28 13:36:33 EDT
Ok I updated the demo in question to use the latest switchyard version and fixed any problems I ran into.  It should run ok now.  You likely still need to update the version in the pom.xml though.

With respect to this comment:

"there is a multitude of pom.xml files that contains definition of of repositories that overrides settings.xml and prevents using delivered offline repos"

I don't quite understand that.  A couple of the demos define a custom maven repository, because that's what's being tested (using the sramp wagon to deploy artifacts from maven directly into the s-ramp repo).  I'm probably missing something...
Comment 4 Eric Wittmann 2013-06-28 13:37:41 EDT
Assigning to ncross as requested by kconner.
Comment 5 Nick Cross 2013-07-02 16:32:23 EDT
Patched in switchyard 1.0.0.alpha version
Comment 7 Len DiMaggio 2013-07-08 17:03:11 EDT
Still seeing an error - see below - with DR7:

[s-ramp-demos-switchyard]$ mvn -e -Pdemo clean deploy
[INFO] Error stacktraces are turned on.
[INFO] Scanning for projects...
[WARNING] The POM for org.overlord.sramp:s-ramp-wagon:jar:0.2.1 is missing, no dependency information available
[ERROR] The build could not read 1 project -> [Help 1]
org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs:
[ERROR] Unresolveable build extension: Plugin org.overlord.sramp:s-ramp-wagon:0.2.1 or one of its dependencies could not be resolved: Failure to find org.overlord.sramp:s-ramp-wagon:jar:0.2.1 in http://repository.jboss.org/nexus/content/groups/developer/ was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced @ 

	at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:339)
	at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:632)
	at org.apache.maven.DefaultMaven.getProjectsForMavenReactor(DefaultMaven.java:581)
	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:233)
	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
[ERROR]   
[ERROR]   The project org.overlord.sramp.demos:s-ramp-demos-switchyard:0.2.1 (/jboss/local/SOA_servers/SOA6/DR7/jboss-eap-6.1/quickstarts/overlord/s-ramp/s-ramp-demos-switchyard/pom.xml) has 1 error
[ERROR]     Unresolveable build extension: Plugin org.overlord.sramp:s-ramp-wagon:0.2.1 or one of its dependencies could not be resolved: Failure to find org.overlord.sramp:s-ramp-wagon:jar:0.2.1 in http://repository.jboss.org/nexus/content/groups/developer/ was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced -> [Help 2]
org.apache.maven.plugin.PluginResolutionException: Plugin org.overlord.sramp:s-ramp-wagon:0.2.1 or one of its dependencies could not be resolved: Failure to find org.overlord.sramp:s-ramp-wagon:jar:0.2.1 in http://repository.jboss.org/nexus/content/groups/developer/ was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced
	at org.apache.maven.plugin.internal.DefaultPluginDependenciesResolver.resolve(DefaultPluginDependenciesResolver.java:215)
	at org.apache.maven.project.DefaultProjectBuildingHelper.resolveExtensionArtifacts(DefaultProjectBuildingHelper.java:377)
	at org.apache.maven.project.DefaultProjectBuildingHelper.createProjectRealm(DefaultProjectBuildingHelper.java:237)
	at org.apache.maven.project.DefaultModelBuildingListener.buildExtensionsAssembled(DefaultModelBuildingListener.java:106)
	at org.apache.maven.model.building.ModelBuildingEventCatapult$1.fire(ModelBuildingEventCatapult.java:43)
	at org.apache.maven.model.building.DefaultModelBuilder.fireEvent(DefaultModelBuilder.java:1041)
	at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:391)
	at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:374)
	at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:536)
	at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:328)
	at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:632)
	at org.apache.maven.DefaultMaven.getProjectsForMavenReactor(DefaultMaven.java:581)
	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:233)
	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
Caused by: org.sonatype.aether.resolution.ArtifactResolutionException: Failure to find org.overlord.sramp:s-ramp-wagon:jar:0.2.1 in http://repository.jboss.org/nexus/content/groups/developer/ was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced
	at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:541)
	at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:220)
	at org.sonatype.aether.impl.internal.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:395)
	at org.apache.maven.plugin.internal.DefaultPluginDependenciesResolver.resolve(DefaultPluginDependenciesResolver.java:207)
	... 24 more
Caused by: org.sonatype.aether.transfer.ArtifactNotFoundException: Failure to find org.overlord.sramp:s-ramp-wagon:jar:0.2.1 in http://repository.jboss.org/nexus/content/groups/developer/ was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced
	at org.sonatype.aether.impl.internal.DefaultUpdateCheckManager.checkArtifact(DefaultUpdateCheckManager.java:190)
	at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:430)
	... 27 more
[ERROR] 
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
[ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
Comment 8 Len DiMaggio 2013-07-08 17:21:34 EDT
Ignore https://bugzilla.redhat.com/show_bug.cgi?id=978229#c7 - user error
Comment 9 Stefan Bunciak 2013-09-18 09:34:22 EDT
Verified with SOA 6.0.0.ER3. S-RAMP quickstarts can be built.

[INFO] 
[INFO] S-RAMP Demos ...................................... SUCCESS [0.670s]
[INFO] S-RAMP Demos: Simple Client ....................... SUCCESS [2.331s]
[INFO] S-RAMP Demos: Archive Package ..................... SUCCESS [0.535s]
[INFO] S-RAMP Demos: Query ............................... SUCCESS [0.406s]
[INFO] S-RAMP Demos: Properties .......................... SUCCESS [0.298s]
[INFO] S-RAMP Demos: Ontologies .......................... SUCCESS [0.282s]
[INFO] S-RAMP Demos: Classifications ..................... SUCCESS [0.196s]
[INFO] S-RAMP Demos: Maven Integration - Artifacts ....... SUCCESS [13.814s]
[INFO] S-RAMP Demos: Maven Integration - App ............. SUCCESS [0.199s]
[INFO] S-RAMP Demos: Maven Integration ................... SUCCESS [0.013s]
[INFO] S-RAMP Demos: Relationships ....................... SUCCESS [0.215s]
[INFO] S-RAMP Demos: Derived Artifacts ................... SUCCESS [0.191s]
[INFO] S-RAMP Demos: Custom Deriver ...................... SUCCESS [0.328s]
[INFO] S-RAMP Demos: Custom Shell Command ................ SUCCESS [0.235s]
[INFO] S-RAMP Demos: Switchyard Deployment ............... SUCCESS [11.132s]
[INFO] S-RAMP Demos: Switchyard Multi App Deployment ..... SUCCESS [0.017s]
[INFO] S-RAMP Demos: Switchyard Multi App Deployment - Service Artifacts  SUCCESS [0.197s]
[INFO] S-RAMP Demos: Switchyard Multi App Deployment - Order Service  SUCCESS [0.582s]
[INFO] S-RAMP Demos: Switchyard Multi App Deployment - Order Consumer  SUCCESS [1.010s]
[INFO] S-RAMP Demos: Switchyard Multi App Deployment - Web App  SUCCESS [9.337s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 43.215s
[INFO] Finished at: Wed Sep 18 15:19:25 CEST 2013
[INFO] Final Memory: 92M/769M
[INFO] ------------------------------------------------------------------------

Note You need to log in before you can comment on or make changes to this bug.