Bug 978242 - [RFE] Allow users to configure which groups are shown by default in My Jobs view
Summary: [RFE] Allow users to configure which groups are shown by default in My Jobs view
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Beaker
Classification: Retired
Component: web UI
Version: 0.13
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
: 978943 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-26 07:29 UTC by Marian Ganisin
Modified: 2018-02-06 00:41 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-15 06:25:57 UTC


Attachments (Terms of Use)

Description Marian Ganisin 2013-06-26 07:29:20 UTC
Description of problem:

Job scheduled with group attribute is shown in 'My jobs' of all group members. This does not seem to be best approach as I expect just my jobs in 'my jobs' view.

Version-Release number of selected component (if applicable):
Version - 0.13.1

How reproducible:
Submit job with group defined, look at 'My jobs' view of other group member.


Actual results:
My jobs does not present list o my jobs anymore, additional jobs that I can manage are shown as well, however I am interested just in those jobs which I submitted when looking to 'My jobs'

Expected results:
just my jobs in 'My jobs'view

Comment 1 Nick Coghlan 2013-06-26 08:34:38 UTC
The expectation for this part of the group jobs feature was that only jobs with genuinely shared responsibility would be marked as a group job.

However, some groups may prefer to use the feature as a "just in case" fallback, so it isn't reasonable to fill up the "My Jobs" list in such cases. This will become even more common once the implicit job sharing behaviour is switched off in a future release.

Something that might handle both use cases is to allow users to define a default groups filter for their My Jobs screen, allowing to choose which groups (if any) show up there.

Comment 2 Nick Coghlan 2013-06-27 07:16:10 UTC
One workaround that provides access to the old-style My Jobs view in 0.13 is to bookmark a URL like the following:

    https://<BEAKER_INSTANCE_URL>/jobs/mine?jobsearch-0.table=Owner%2FUsername&jobsearch-0.operation=is&jobsearch-0.value=<USERNAME>&Search=Search

This can be generated using the search filter on the My Jobs page to set "Owner/Username" to your own username.

Comment 3 Nick Coghlan 2013-06-27 23:59:43 UTC
A possible alternative to making this a separate configuration option is to limit the included group jobs to those where the user is included in the CC list.

Comment 4 Nick Coghlan 2013-06-28 00:04:06 UTC
*** Bug 978943 has been marked as a duplicate of this bug. ***

Comment 5 Nick Coghlan 2013-07-15 06:25:57 UTC
For 0.14, we're going to revert My Jobs to its old behaviour (bug 984374) and add a new screen with the new behaviour (bug 984382)


Note You need to log in before you can comment on or make changes to this bug.