Bug 978255 - autopart (use free space) install does not report that existing partitions will remain untouched
autopart (use free space) install does not report that existing partitions wi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 04:13 EDT by Peter Kotvan
Modified: 2013-08-02 07:08 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 20:44:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing INSTALLATION OPTIONS dialog described in Comment 4 (71.50 KB, image/png)
2013-08-01 07:51 EDT, Steve Tyler
no flags Details
screenshot showing SUMMARY OF CHANGES dialog after completing Manual Partitioning (85.54 KB, image/png)
2013-08-01 08:02 EDT, Steve Tyler
no flags Details

  None (edit)
Description Peter Kotvan 2013-06-26 04:13:12 EDT
Description of problem:
When installing f19 on system with existing partitions and enough free space, option for automatic configuration does not inform that existing partitions and file systems will be preserved during the installation.

Version-Release number of selected component (if applicable):
f19rc2, anaconda-19.30.12-1

How reproducible:
Do automatic install of f19 on system with existing partitions (or existing system installed).

Steps to Reproduce:
1. Have a machine with existing partitions or installed system. Ensure that there is enough free space on discs for new fedora installation.
2. During the installation of new system select automatic installation using free space.

Actual results:
Anaconda does not inform user that existing partitions will not be modified or deleted during the installation

Expected results:
Anaconda should state that existing partitions will remain untouched after installation of f19.
Comment 1 Brian Lane 2013-06-26 20:44:40 EDT
Well, that's what 'use free space' means.
Comment 2 Steve Tyler 2013-08-01 01:02:49 EDT
Sheesh, Peter was just asking for a more detailed report of what the installer is going to do when autopart is selected. How hard is that to understand?
Comment 3 Steve Tyler 2013-08-01 01:14:29 EDT
Peter: Where in the GUI would you propose that information be presented?
Comment 4 Peter Kotvan 2013-08-01 03:07:18 EDT
I tried this once again in a virtual machine. After i selected the disc with existing partitions i got this exactly:

INSTALLATION OPTIONS

You have ....GB of free space, which is enough to install Fedora. What would you like to do?

* Automatically configure my Fedora installation to disk(s) I selected and return me to the main menu.

Then follow other options that are not important in this case.

When I see "Automatically configure" it makes me little suspicious because I'm going to let installer mess with my disks/partitions. So I think that installer should explicitly say that existing partitions will remain as they are. I would expect something like this:

* Automatically configure my Fedora installation to disk(s) I selected and return me to the main menu. Existing partitions will be preserved.
Comment 5 Steve Tyler 2013-08-01 07:51:29 EDT
Created attachment 781541 [details]
screenshot showing INSTALLATION OPTIONS dialog described in Comment 4

Thanks for your comments. I understand your suspicions ... :-)

Since you are testing in a VM, you can easily take screenshots and attach them to this bug. This attachment shows the dialog you are referring to.

The additional wording sounds good to me:
"Existing partitions will be preserved."
Comment 6 Steve Tyler 2013-08-01 08:02:06 EDT
Created attachment 781547 [details]
screenshot showing SUMMARY OF CHANGES dialog after completing Manual Partitioning

After completing Manual Partitioning, the installer displays an informative SUMMARY OF CHANGES dialog listing all of the changes to the disk(s) that will take effect after installation begins. Could you comment on it?

Although you can't tell from the screenshot, there is a second disk, sdb, which I did not select as a possible install target.

Tested with:
$ qemu-kvm -m 2048 -hda f19-test-2.img -hdb f20-test-1.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on
Comment 7 Steve Tyler 2013-08-01 08:08:33 EDT
(In reply to Peter Kotvan from comment #4)
...
> * Automatically configure my Fedora installation to disk(s) I selected and
> return me to the main menu. Existing partitions will be preserved.
                                       ^^^^^^^^^^
There could be logical volumes too ...
Comment 8 Peter Kotvan 2013-08-02 06:53:03 EDT
(In reply to Steve Tyler from comment #6)
...
> Although you can't tell from the screenshot, there is a second disk, sdb,
> which I did not select as a possible install target.

Is there another LVM physical volume on sdb? I am not sure what should be the right behaviour in this case...
Comment 9 Peter Kotvan 2013-08-02 06:57:00 EDT
(In reply to Steve Tyler from comment #7)
...
> There could be logical volumes too ...

What about this: Existing volumes will be preserved. ?
Comment 10 Steve Tyler 2013-08-02 07:08:04 EDT
(In reply to Peter Kotvan from comment #9)
> (In reply to Steve Tyler from comment #7)
> ...
> > There could be logical volumes too ...
> 
> What about this: Existing volumes will be preserved. ?

I believe Adam W. has proposed that terminology, although I would amend it to:
Existing storage volumes will be preserved.
         ^^^^^^^

CCing Adam for comment.

Note You need to log in before you can comment on or make changes to this bug.