Bug 978300 - [Hyper-V][RHEL6.5]Failed to start the hypervkvpd service with error "Hyper-V drivers are not loaded"
[Hyper-V][RHEL6.5]Failed to start the hypervkvpd service with error "Hyper-V ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hypervkvpd (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Tomáš Hozza
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 06:02 EDT by Shengnan Wang
Modified: 2013-11-20 23:52 EST (History)
5 users (show)

See Also:
Fixed In Version: hypervkvpd-0-0.11.el6
Doc Type: Bug Fix
Doc Text:
There was a typographical error in the command that verifies the Hyper-V para-virtualized drivers. Consequently, the hyperkvpd service failed to start, and it displayed an error message "Hyper-V drivers are not loaded". The command has been modified, and the "-q" option of the grep command-line utility has been removed. As a result, the service now successfully starts without an error.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 23:52:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1539 normal SHIPPED_LIVE hypervkvpd bug fix update 2013-11-20 16:40:49 EST

  None (edit)
Description Shengnan Wang 2013-06-26 06:02:06 EDT
Description of problem:
Failed to start the hypervkvpd service with error "Hyper-V drivers are not loaded".  There was a typo in the command that check the hyper-v pv drivers in the file /etc/rc.d/init.d/hypervkvd. It should be ture always with the command 'if [ -z "`lsmod | grep -q hv_utils`" ]'. It should be   'if [ -z "`lsmod | grep hv_utils`" ]'.

...........

  if [ -z "`lsmod | grep -q hv_utils`" ]; then
                echo "Hyper-V drivers are not loaded."
                echo -n "Hyper-V KVP daemon not started:"
                warning

...........


# lsmod |grep hv
hv_utils                5956  0 
...............


Version-Release number of selected component (if applicable):
Host: Windows 2012  Hyper-V Server Core
Guest: Both i386 and x86_64 RHEL6 guest (kernel-2.6.32-358.el6)
       Hypervkvpd pacakge hypervkvpd-0-0.10.el6


How reproducible:
100%

Steps to Reproduce:
1.Install hypervkvpd pacakge hypervkvpd-0-0.10.el6
# rpm -ivh hypervkvpd-0-0.10.el6.*
2.Start the hypervkvpd service.
# service hypervkvpd start
3.Check the status of the hypervkvpd service.
# service hypervkvpd status


Actual results:

At step2, failed to start the service with the error "Hyper-V drivers are not loaded"
At step3, the status is stopped.



Expected results:

At step2, start the service successfully without errors.
At step3, the status is running.

Additional info:
1. No this problem with hypervkvpd-0-0.9.3.el6 & hypervkvpd-0-0.9.2.el6 packages.
Comment 1 Tomáš Hozza 2013-06-26 06:16:59 EDT
True, there should not be "-q" option when calling grep.
Comment 2 RHEL Product and Program Management 2013-06-26 07:00:03 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 8 lijing 2013-09-12 23:11:23 EDT
verify this bug on x86_64 and i386 with rhel6.5 guest(kernel:2.6.32-415.0.1.el6) 
the hypervkvpd server start successfully.
package version:
hypervkvpd-0-0.12.el6

so verify this bug
Comment 10 errata-xmlrpc 2013-11-20 23:52:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1539.html

Note You need to log in before you can comment on or make changes to this bug.