Bug 978310 - [RHSC] When trying to reset all options set on the volume, it still retains one option calles user.cifs=on on 2.0U5 nodes.
[RHSC] When trying to reset all options set on the volume, it still retains o...
Status: CLOSED DUPLICATE of bug 880058
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Sahina Bose
RamaKasturi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 06:41 EDT by RamaKasturi
Modified: 2013-07-03 05:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-03 05:54:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attaching engine and vdsm logs. (5.82 MB, text/x-log)
2013-06-26 06:41 EDT, RamaKasturi
no flags Details

  None (edit)
Description RamaKasturi 2013-06-26 06:41:43 EDT
Created attachment 765506 [details]
Attaching engine and vdsm logs.

Description of problem:
When trying to reset all options set on the volume, it still retains one option calles user.cifs=on.

Version-Release number of selected component (if applicable):
glusterfs-3.3.0.10rhs-1.el6rhs.x86_64
vdsm-4.9.6-24.el6rhs.x86_64
rhsc-2.1.0-0.bb4.el6rhs.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a 3.1 cluster and add 2.0U5 nodes to it.
2. Create a volume from rhsc UI
3. Now click on the volume created , and click on the Volume Options subtab and click "Reset All" link.

Actual results:
It removes all the options expect user.cifs option and event tab says that "volume options has been reset"and "Detected new option user.cifs=on on volume Vol4 of cluster Cluster_anshi, and added it to engine DB."

Expected results:
It should all the avialable options from the volume.

Additional info:
Comment 2 Sahina Bose 2013-07-02 02:15:28 EDT
Possibly a glusterfs bug
Comment 3 Sahina Bose 2013-07-03 05:54:11 EDT

*** This bug has been marked as a duplicate of bug 880058 ***

Note You need to log in before you can comment on or make changes to this bug.