Bug 978394 - Cannot download spreadsheet DT with name containing whitespaces
Cannot download spreadsheet DT with name containing whitespaces
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER2
: 6.0.0
Assigned To: manstis
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 10:14 EDT by Jiri Locker
Modified: 2014-08-06 16:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:20:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Locker 2013-06-26 10:14:00 EDT
Description of problem:
Downloading such spreadsheet results with HTTP 500 status caused by uncaught exception:

org.kie.commons.java.nio.IOException: Illegal character in path at index 62: default://master@uf-playground/mortgages/src/main/resources/my decision table.dtable.xls
	org.kie.workbench.common.services.backend.file.upload.AbstractFileServlet.processAttachmentDownload(AbstractFileServlet.java:261)
	org.kie.workbench.common.services.backend.file.upload.AbstractFileServlet.doGet(AbstractFileServlet.java:236)
        ...

Version-Release number of selected component (if applicable):
DR5

How reproducible:
always

Steps to Reproduce:
1. create new spreadsheet DT named "my decision table" (be aware of bug 978366)
2. open it and click Download button

Actual results:
HTTP 500, uncaught exception

Expected results:
Should be possible to download the file.

Additional info:
Comment 2 Jiri Locker 2013-09-12 10:08:36 EDT
Verified in ER2.

Note You need to log in before you can comment on or make changes to this bug.