Bug 978414 - httpd.service fails to start due to mod_python.so not loading
httpd.service fails to start due to mod_python.so not loading
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 10:44 EDT by George Galt
Modified: 2013-06-26 12:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 12:57:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Galt 2013-06-26 10:44:25 EDT
Description of problem: When attempting to start httpd.service, service fails to start with:
Jun 26 10:22:31 server.galtfamily.net httpd[5458]: httpd: Syntax error on line 353 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/conf.d/python.conf: Cannot load modules/mod_python.so into server: /etc/httpd/modules/mod_python.so: undefined symbol: ap_my_generation
Jun 26 10:22:31 server.galtfamily.net systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Jun 26 10:22:31 server.galtfamily.net httpd[5460]: httpd: Syntax error on line 353 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/conf.d/python.conf: Cannot load modules/mod_python.so into server: /etc/httpd/modules/mod_python.so: undefined symbol: ap_my_generation
Jun 26 10:22:31 server.galtfamily.net systemd[1]: httpd.service: control process exited, code=exited status=1
Jun 26 10:22:31 server.galtfamily.net systemd[1]: Failed to start The Apache HTTP Server.
-- Subject: Unit httpd.service has failed
-- Defined-By: systemd


Version-Release number of selected component (if applicable):
httpd-2.4.4-6

How reproducible:
Every time I attempt to start httpd.service


Steps to Reproduce:
1.systemctl start httpd.service
2.
3.

Actual results:
Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl -xn' for details.



Expected results:
httpd.service success

Additional info:
This is a fresh install of Fedora 17, immediately upgraded through fedup to Fedora 19.  No modification of any config files or other files.  httpd.service failed the first time it was tried immediately after upgrading to Fedora 19.  It was not tried prior to the upgrade to Fedora 19.

mod_python.so exists in /usr/lib64/httpd/modules/mod_python.so and there is a link from /etc/httpd/modules to /usr/lib64/httpd/modules/mod_python.so 
[mythtv@server ~]$  ls -l /etc/httpd/modules
lrwxrwxrwx. 1 root root 29 Jun 22 21:45 /etc/httpd/modules -> ../../usr/lib64/httpd/modules
Comment 1 Jan Kaluža 2013-06-26 12:57:47 EDT
There is no mod_python in Fedora 19: https://admin.fedoraproject.org/pkgdb/acls/name/mod_python .

You are trying to use mod_python from Fedora 17 with httpd from Fedora 19. Uninstall mod_python and httpd should start normally. I'm closing this one as WONTFIX, since it's expected behaviour.

Note You need to log in before you can comment on or make changes to this bug.