Bug 978429 - agent is not able to discover resources when running under different java architecture
agent is not able to discover resources when running under different java arc...
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: Agent (Show other bugs)
JON 3.1.2
Unspecified Solaris
medium Severity high
: ---
: JON 3.3.0
Assigned To: Lukas Krejci
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 11:04 EDT by Libor Fuka
Modified: 2014-09-04 10:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-04 10:17:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Discovery issue on Solaris (4.58 KB, text/plain)
2013-07-30 03:18 EDT, Radim Hatlapatka
no flags Details

  None (edit)
Description Libor Fuka 2013-06-26 11:04:38 EDT
Description of problem:



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start agent under 32bit java on Solaris Intel
2. Start tomcat under 64bit java on Solaris Intel
3. discover in agent prompt
4. tomcat is not discovered

When agent is started in 64bit java on Solaris Intel and Tomcat also under 64bit java on Solaris Intel Tomcat is discovered without problem

Actual results:


Expected results:


Additional info:
Comment 1 Mike Foley 2013-06-26 11:32:45 EDT
increasing the severity  and  setting the target release so this gets triaged for JON 3.2
Comment 2 Lukas Krejci 2013-07-03 12:34:54 EDT
Tried the following combinations with RHQ 4.8.0 (on RHEL6.3/x86_64):

Agent 64bit + Tomcat 32bit = discovered
Agent 32bit + Tomcat 64bit = discovered

So in another words this seems to be only happening on Solaris.
Comment 3 Radim Hatlapatka 2013-07-30 03:09:47 EDT
Yes, the issue is happening only on Solaris.
Comment 4 Radim Hatlapatka 2013-07-30 03:18:58 EDT
Created attachment 780381 [details]
Discovery issue on Solaris

In the attachment you can see, that EAP 6 running in domain mode is not discovered even though the process is recognized as part of JMX.JMX Server (there are also printed all running processes under current user)

In this case the difference is that agent starts with jdk for solaris10 (I need to figure out why) and EAP 6 uses correctly jdk for solaris 11
Comment 9 Libor Fuka 2014-09-03 07:30:54 EDT
I retested it with this environment:
Solaris 10 Intel
JON 3.3.0.ER1.1
agent OracleJDK 1.6 32-bit
tomcat7 OracleJDK 1.6 64-bit
tomcat7 discovery works fine.

When i set this environment:
Solaris 10 Intel
JON 3.3.0.ER1.1
agent OracleJDK 1.6 64-bit
tomcat7 OracleJDK 1.6 32-bit
tomcat7 discovery also works fine.
Comment 10 Libor Fuka 2014-09-03 10:45:52 EDT
I retested it with this environment:
Solaris 11 Intel
JON 3.3.0.ER1.1
agent OracleJDK 1.6 32-bit
tomcat7 OracleJDK 1.7 64-bit
and tomcat7 discovery still doesn't work.
Comment 11 Libor Fuka 2014-09-04 07:43:28 EDT
installed server with testing server sent to Lukas
Comment 12 Lukas Krejci 2014-09-04 10:17:06 EDT
This is a limitation of the Sigar library that cannot inspect 64 bit processes when running in a 32bit mode and vice versa on Solaris, see the comment in Sigar source code:
https://github.com/hyperic/sigar/blob/master/src/os/solaris/solaris_sigar.c#L944

I'm closing this as WONTFIX as this is a limitation of the underlying library.

The workaround is to add the tomcat instance manually.

Note You need to log in before you can comment on or make changes to this bug.