Bug 978552 - Extend GlusterFS CInder Plugin to support Cinder Backup
Extend GlusterFS CInder Plugin to support Cinder Backup
Status: CLOSED UPSTREAM
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
Unspecified Unspecified
high Severity medium
: Upstream M1
: 6.0 (Juno)
Assigned To: Eric Harney
Yogev Rabl
https://blueprints.launchpad.net/cind...
storage
: FutureFeature
Depends On:
Blocks: 1072221
  Show dependency treegraph
 
Reported: 2013-06-26 15:03 EDT by Tushar Katarki
Modified: 2016-04-26 09:29 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1072221 (view as bug list)
Environment:
Last Closed: 2014-08-26 14:31:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1275977 None None None Never
OpenStack gerrit 70201 None None None Never
OpenStack gerrit 70405 None None None Never

  None (edit)
Description Tushar Katarki 2013-06-26 15:03:29 EDT
Description of problem:

OpenStack Havana targets to have a new service called Cinder Backup for Cinder Volumes.

The blueprint is here: https://blueprints.launchpad.net/cinder/+spec/volume-backups

and the implementation is here: https://review.openstack.org/#/c/19468/

This BZ requests extending the Cinder Plugin glusterfs to support Cinder Backup.
Comment 2 Eric Harney 2013-08-23 01:32:08 EDT
This looks increasingly unlikely to land in Havana upstream due to the requirement to support GlusterFS in Brick.  A patch has been proposed to add NFS support to Brick which may help us if it gains acceptance.
Comment 13 Yogev Rabl 2014-05-29 03:04:27 EDT
Eric, can you please provide some information about how to configure the GlusterFS as a backup driver?
Comment 14 Eric Harney 2014-05-29 09:40:17 EDT
(In reply to Yogev Rabl from comment #13)
There is no GlusterFS backup driver.  This is only for backup support for the GlusterFS volume driver.

Note You need to log in before you can comment on or make changes to this bug.