Bug 978779 - please update package to use proper language code
please update package to use proper language code
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tesseract-langpack (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karol Trzcionka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 02:52 EDT by Parag Nemade
Modified: 2013-09-13 22:33 EDT (History)
1 user (show)

See Also:
Fixed In Version: tesseract-3.02.02-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 22:33:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modified spec file to address reported issue (26.54 KB, text/x-rpm-spec)
2013-06-27 02:52 EDT, Parag Nemade
no flags Details

  None (edit)
Description Parag Nemade 2013-06-27 02:52:37 EDT
Created attachment 765961 [details]
Modified spec file to address reported issue

Description of problem:
I see that tesseract-langpack using the same locale code that upstream provides but then this created problem when we try to install any language support.

e.g. "yum langinstall pt" does not pick Polish translation of tesseract-langpack

if we change tesseract-langpack-pol to tesseract-langpack-pt then we can get this translation installed as well.

Likewise for all other languages we need 2 letter iso-code wherever its available.

I am attaching here new spec that will fix language code. Please use this and build new package.

Version-Release number of selected component (if applicable):
tesseract-3.02.02-1.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
unknown language code for yum langinstall command

Expected results:
use known iso-codes 2 letter language code wherever possible.

Additional info:
Comment 1 Fedora Update System 2013-06-28 15:13:56 EDT
tesseract-3.02.02-1.fc19, tesseract-langpack-3.02-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-6867/tesseract-langpack-3.02-5.fc19,tesseract-3.02.02-1.fc19
Comment 2 Parag Nemade 2013-06-29 09:24:55 EDT
I have seen this approach used in kde-l10n packages. But they do have correct naming like say -Polish for pl language code whereas package name in tesseract-langpack has been kept as -pol.

I am writing a langavailable command for yum-langpacks where internally I am generating available language codes and then based on that provide output. e.g. "yum langavailable pl". 

Due to inconsistent package naming I cannot use tesseract-langpack packages now but still based on other packages using -pl, we can get "pl is available" output. But, if tesseract-langpack provides any language translation which is not available for any other package then we may miss that language from listing it as a available.

For kde-l10n, I can get Polish converted to pl using its 2 letter iso-codes but with pol no way to get back 2-letter-code.

Anyway thanks for fixing to provide 2-letter language code at least.
Comment 3 Fedora Update System 2013-06-29 14:27:13 EDT
Package tesseract-3.02.02-1.fc19, tesseract-langpack-3.02-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tesseract-3.02.02-1.fc19 tesseract-langpack-3.02-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6867/tesseract-langpack-3.02-5.fc19,tesseract-3.02.02-1.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-07-23 23:27:48 EDT
Package tesseract-3.02.02-1.fc19, tesseract-langpack-3.02-6.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tesseract-3.02.02-1.fc19 tesseract-langpack-3.02-6.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6867/tesseract-langpack-3.02-6.fc19,tesseract-3.02.02-1.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-09-13 22:33:24 EDT
tesseract-3.02.02-1.fc19, tesseract-langpack-3.02-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.