Bug 978866 - SELinux is preventing /usr/lib64/firefox/firefox from using the execmem access on a process
SELinux is preventing /usr/lib64/firefox/firefox from using the execmem acces...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox (Show other bugs)
6.5
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Red Hat Gecko Maintainer
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 04:58 EDT by Siddharth
Modified: 2014-02-02 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 10:05:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Siddharth 2013-06-27 04:58:53 EDT
Description of problem:
firefox segfault due to SELinux is preventing it from using execmem

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 6.4
firefox-17.0.6-1.el6_4

How reproducible:
always

Steps to Reproduce:
1.run firefox
2.crash
3.

Actual results:
firefox crash

Expected results:
firefox would not crash

Additional info:
Comment 2 Martin Stransky 2013-10-08 10:05:18 EDT
Yes, it's because of the JIT compiler. But mozilla refuses to include our patch which fixes this issue. So we don't have any fix for that on Firefox side.

Note You need to log in before you can comment on or make changes to this bug.