Bug 978931 - GeoIP-devel missing pkg-config
GeoIP-devel missing pkg-config
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: GeoIP (Show other bugs)
el6
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 06:09 EDT by Halfasleep
Modified: 2014-07-28 11:26 EDT (History)
4 users (show)

See Also:
Fixed In Version: GeoIP-1.5.1-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-28 11:26:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Halfasleep 2013-06-27 06:09:45 EDT
When trying to configure software with a dependency on geoip, pkg-config cannot find the library due to missing .pc file. 

Version-Release number of selected component (if applicable):


How reproducible:
Always


Actual results:
Require "GEOIP_LIBS=/usr/include/ GEOIP_CFLAGS=-I/usr/include ./configure" to build
Comment 1 Fabien Wernli 2013-11-05 06:34:40 EST
I can confirm this issue.
Comment 2 Scott K Logan 2014-05-05 17:46:04 EDT
FYI:

F20 and rawhide have a geoip.pc installed. It was added in upstream 1.5.0. It looks like the package source has 1.5.0-6 as the latest EL6 release [1], but it hasn't been pushed to bodhi...

[1] http://pkgs.fedoraproject.org/cgit/GeoIP.git/?h=el6
Comment 3 Paul Howarth 2014-07-28 11:26:28 EDT
This has been fixed with the recent update to GeoIP-1.5.1-5.el6.

Note You need to log in before you can comment on or make changes to this bug.