Bug 978936 - Letter case changes in gluster volume heal command
Letter case changes in gluster volume heal command
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: vsomyaju
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 06:14 EDT by vsomyaju
Modified: 2015-03-04 19:06 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:43:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vsomyaju 2013-06-27 06:14:35 EDT
Description of problem:
Letter case change need in output 
1. Gathering Heal info
2. Launching Heal operation

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Create replicate volume
2. start volume
3. Mount volume
4. Execute "gluster volume heal volume-name"
5. Execute "gluster volume heal volume-name info"

Actual results:



Expected results:
Change Heal to heal in both outputs

Additional info:
Comment 1 Anand Avati 2013-06-27 06:19:45 EDT
REVIEW: http://review.gluster.org/5259 (cli: Fix in letter case in volume heal output) posted (#1) for review on master by venkatesh somyajulu (vsomyaju@redhat.com)
Comment 2 vsomyaju 2013-06-27 06:20:28 EDT
http://review.gluster.com/#/c/5259/
Comment 3 Anand Avati 2013-07-04 01:30:34 EDT
COMMIT: http://review.gluster.org/5259 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 291344f9c80fe1a3c0fe784a1642da6795dcf5a4
Author: Venkatesh Somyajulu <vsomyaju@redhat.com>
Date:   Thu Jun 27 15:47:01 2013 +0530

    cli: Fix in letter case in volume heal output
    
    Change-Id: I25d13444c2cbff9b26642e91677ad1e09e77aa1e
    BUG: 978936
    Signed-off-by: Venkatesh Somyajulu <vsomyaju@redhat.com>
    Reviewed-on: http://review.gluster.org/5259
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 4 Anand Avati 2013-07-04 06:45:30 EDT
REVIEW: http://review.gluster.org/5286 (cli: volume heal commands will list the display the command type.) posted (#1) for review on master by venkatesh somyajulu (vsomyaju@redhat.com)
Comment 5 Anand Avati 2013-07-05 02:05:29 EDT
REVIEW: http://review.gluster.org/5286 (cli: gluster volume heal commands are more elaborative) posted (#2) for review on master by venkatesh somyajulu (vsomyaju@redhat.com)
Comment 6 Anand Avati 2013-07-05 02:17:07 EDT
REVIEW: http://review.gluster.org/5286 (cli: gluster volume heal commands are more elaborative) posted (#3) for review on master by venkatesh somyajulu (vsomyaju@redhat.com)
Comment 7 Anand Avati 2013-07-24 08:18:42 EDT
COMMIT: http://review.gluster.org/5286 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 59dde88921ba506800c55f583c679630f85290e1
Author: Venkatesh Somyajulu <vsomyaju@redhat.com>
Date:   Thu Jul 4 16:07:59 2013 +0530

    cli: gluster volume heal commands are more elaborative
    
    1. "gluster volume heal volume-name"
    output :Launching heal operation to perform index self heal on volume volume-name has been successful
    
    2. "gluster volume heal volume-name full"
    Output :Launching heal operation to perform full self heal on volume volume-name has been successful
    
    3. "gluster volume heal volume-name info"
    Output :Gathering list of entries to be healed on volume volume-name has been successful
    
    4. "gluster volume heal volume-name info healed"
    Output :Gathering list of healed entries on volume volume-name has been successful
    
    5. "gluster volume heal volume-name info split-brain"
    Output :Gathering list of split brain entries on volume volume-name has been successful
    
    6. "gluster volume heal volume-name info heal-failed"
    Output :Gathering list of heal failed entries on volume volume-name has been successful
    
    Change-Id: I74c90e8129d23d513ddb7879358a9d21c94a5c0d
    BUG: 978936
    Signed-off-by: Venkatesh Somyajulu <vsomyaju@redhat.com>
    Reviewed-on: http://review.gluster.org/5286
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 8 Niels de Vos 2014-04-17 07:43:00 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.