Bug 979004 - Endpoints for Nova Compute are incorrect
Endpoints for Nova Compute are incorrect
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Stephen Gordon
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 08:58 EDT by Julie Pichon
Modified: 2015-02-15 17:02 EST (History)
2 users (show)

See Also:
Fixed In Version: Red_Hat_OpenStack-Installation_and_Configuration_Guide-3-en-US-3-26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 15:14:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julie Pichon 2013-06-27 08:58:14 EDT
Document URL: 
https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack/3/html/Installation_and_Configuration_Guide/Creating_the_Compute_Service_Endpoint.html

Section Number and Name: 
10.3.3. Creating the Red Hat OpenStack Compute Identity Records

Describe the issue: 
The Keystone endpoints are incorrect.

Suggestions for improvement: 
For Nova I believe this should be:

keystone endpoint-create \
 --service-id=SERVICEID \
 --publicurl='http://IP:8774/v2/%(tenant_id)s' \
 --internalurl='http://IP:8774/v2/%(tenant_id)s' \
 --adminurl='http://IP:8774/v2/%(tenant_id)s'

Additional information:
Comment 1 Stephen Gordon 2013-06-27 09:02:47 EDT
In RHOS 2.1 we had this (the one in the new guide looks like the Quantum endpoint incorrectly copied over):

$ keystone endpoint-create --service_id 9f004f52a97e469b9983d5adefe9f6d0 \
  --publicurl "http://192.0.43.10:8774/v1.1/\$(tenant_id)s" \
  --adminurl "http://192.0.43.10:8774/v1.1/\$(tenant_id)s" \
  --internalurl "http://192.0.43.10:8774/v1.1/\$(tenant_id)s"

Just need to confirm v2 is indeed the API version now, checking my install.
Comment 2 Stephen Gordon 2013-06-27 09:06:06 EDT
Confirmed, correct form for Compute is port 8774, v2, with the trailing tenant identifier marker.
Comment 3 Stephen Gordon 2013-06-27 09:16:49 EDT
"Creating the Red Hat OpenStack Compute Identity Records" - ID: 15862 [rev: 472143]

Note You need to log in before you can comment on or make changes to this bug.