Bug 979091 - hibernate.id.new_generator_mappings default value incorrect
hibernate.id.new_generator_mappings default value incorrect
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: EAP 6.2.0
Assigned To: Lucas Costi
Russell Dickenson
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 11:00 EDT by Bryan
Modified: 2014-08-14 11:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.8 Build Name: 11864, Development Guide-6.1-3 Build Date: 19-04-2013 15:35:25
Last Closed: 2013-12-15 11:20:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan 2013-06-27 11:00:29 EDT
Title: Hibernate Configuration Properties

Describe the issue:
the default for the hibernate.id.new_generator_mappings property is incorrect
The document has it listed as false as the default, but in testing it seems to be defaulted to true.  

Suggestions for improvement:
Change the property value and update the starred note below to say that new project by default get the new generators and applications being migrated from a pervious version should set it to false 

Additional information:
The migration document seems to have this property defined correctly
https://access.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.1/html-single/Migration_Guide/index.html
Comment 5 Lucas Costi 2013-10-29 00:20:29 EDT
Changes made to topic 7447, revision 549386.

The changes will be reflected in the next document build, and the status will be changed to ON_QA when it is ready for review.
Comment 7 Martin Simka 2013-11-01 07:44:47 EDT
verified

Note You need to log in before you can comment on or make changes to this bug.