Bug 979119 - [abrt] system-config-printer-libs-1.4.1-7.fc19: jobviewer.py:1953:job_event:TypeError: encode() argument 2 must be string, not int
[abrt] system-config-printer-libs-1.4.1-7.fc19: jobviewer.py:1953:job_event:T...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:37333d5da2232d14c0d38688a89...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 12:21 EDT by Mukundan Ragavan
Modified: 2013-07-23 23:27 EDT (History)
2 users (show)

See Also:
Fixed In Version: system-config-printer-1.4.1-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 23:27:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.56 KB, text/plain)
2013-06-27 12:22 EDT, Mukundan Ragavan
no flags Details
File: environ (655 bytes, text/plain)
2013-06-27 12:22 EDT, Mukundan Ragavan
no flags Details

  None (edit)
Description Mukundan Ragavan 2013-06-27 12:21:58 EDT
Version-Release number of selected component:
system-config-printer-libs-1.4.1-7.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/share/system-config-printer/scp-dbus-service.py
core_backtrace: 64777d4ce2431b3a73aac9da094d6cf16a11efa9 0x7a1 job_event /usr/share/system-config-printer/jobviewer.py -
executable:     /usr/share/system-config-printer/scp-dbus-service.py
kernel:         3.9.6-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
jobviewer.py:1953:job_event:TypeError: encode() argument 2 must be string, not int

Traceback (most recent call last):
  File "/usr/share/system-config-printer/jobviewer.py", line 1953, in job_event
    (document.encode ('utf-8', jobid)))
TypeError: encode() argument 2 must be string, not int

Local variables in innermost frame:
may_be_problem: True
notify_text: u'Printer stopped due to backend errors; please consult the error_log file for details.'
self: <JobViewer object at 0x134d280 (jobviewer+JobViewer at 0xd01900)>
uri: u'ipp://carbon/printers/MFP1815'
jobdata: {'job-name': u'Test Page', 'job-printer-uri': u'ipp://carbon/printers/MFP1815', 'attributes-charset': u'utf-8', 'job-k-octets': 0, 'attributes-natural-language': u'en-us', 'job-printer-name': 'MFP1815', 'time-at-creation': 1372349890, 'job-state': 3}
jobid: 12
eventname: 'job-state-changed'
printer: 'MFP1815'
mon: <Monitor object at 0x15e12d0 (monitor+Monitor at 0x13f8640)>
jstate: 3
document: u'Test Page'
event: {'job-name': u'Test Page', 'notify-job-id': 12, 'printer-state': 4, 'notify-subscription-id': 7, 'notify-subscribed-event': u'job-state-changed', 'printer-state-reasons': [u'none'], 'job-impressions-completed': 1, 'printer-is-accepting-jobs': True, 'notify-printer-uri': u'ipp://carbon/printers/MFP1815', 'job-state-reasons': u'none', 'notify-sequence-number': 46, 'notify-text': u'Printer stopped due to backend errors; please consult the error_log file for details.', 'printer-name': u'MFP1815', 'notify-charset': u'utf-8', 'printer-up-time': 1372349895, 'notify-natural-language': u'en-us', 'job-state': 3}
Comment 1 Mukundan Ragavan 2013-06-27 12:22:03 EDT
Created attachment 766249 [details]
File: backtrace
Comment 2 Mukundan Ragavan 2013-06-27 12:22:06 EDT
Created attachment 766250 [details]
File: environ
Comment 3 Tim Waugh 2013-07-02 04:21:52 EDT
Fixed upstream in commit 557a198.
Comment 4 Fedora Update System 2013-07-02 08:55:40 EDT
system-config-printer-1.4.1-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-printer-1.4.1-8.fc19
Comment 5 Fedora Update System 2013-07-02 21:36:43 EDT
Package system-config-printer-1.4.1-8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.4.1-8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12150/system-config-printer-1.4.1-8.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-07-23 23:27:12 EDT
system-config-printer-1.4.1-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.