Bug 979256 - [Docs][Tech Ref] Using required networks in defining cluster/migration policy
[Docs][Tech Ref] Using required networks in defining cluster/migration policy
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.3.0
Assigned To: Zac Dover
ecs-bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 01:20 EDT by Cheryn Tan
Modified: 2014-06-18 03:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-06 23:06:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cheryn Tan 2013-06-28 01:20:36 EDT
Source content: 
https://access.redhat.com/site/solutions/402913

This bug requests more detail in the "Required Networks, Optional Networks, and Virtual Machine Networks" topic, specifically with regards to creating scheduling and migration policies. 

For example, this topic can explain:
1. When a required network becomes non-operational, the virtual machines running on the network are fenced and migrated to another host. This is useful for machines running mission critical workloads.

2. When a non-required network becomes non-operational, the virtual machines running on the network will not be migrated to another host. This is useful for virtual machines running non-critical operations, as it prevents unnecessary I/O overload caused by mass migrations.

https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.2/html-single/Technical_Reference_Guide/index.html#Virtual_Machine_Networks_and_Optional_Networks

(It might also be worth adding mention of required networks for high availability virtual machines, but I haven't found a good place for this information)
Comment 1 Zac Dover 2013-08-27 22:57:08 EDT
Topic 10994 updated as described below.
Revision History [21138] updated.
3.3.0-004
Moving to POST.


What Changed
------------
I added the following paragraphs:

  When a non-required network becomes non-operational, the virtual machines
  running on the network are not migrated to another host. This prevents 
  unnecessary I/O overload caused by mass migrations.

  When a required network becomes non-operational, the virtual machines 
  running on the network are fenced and migrated to another host. This 
  is beneficial if you have machines running mission critical workloads.
Comment 2 Zac Dover 2013-09-24 21:23:04 EDT
Documentation Link
------------------
http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Enterprise_Virtualization/3.3/html-single/Technical_Reference_Guide/index.html#Virtual_Machine_Networks_and_Optional_Networks

What Changed
------------
I added the following paragraphs:

  When a non-required network becomes non-operational, the virtual machines
  running on the network are not migrated to another host. This prevents 
  unnecessary I/O overload caused by mass migrations.

  When a required network becomes non-operational, the virtual machines 
  running on the network are fenced and migrated to another host. This 
  is beneficial if you have machines running mission critical workloads.

NVR
---
Red_Hat_Enterprise_Virtualization-Technical_Reference_Guide-3.3-en-US-3.3.0-004

Moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.