Bug 97926 - dlmod: Dynamic modules not support
dlmod: Dynamic modules not support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: ucd-snmp (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks: 106715
  Show dependency treegraph
 
Reported: 2003-06-24 03:16 EDT by Sandeep goyal
Modified: 2015-03-04 20:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-09 05:42:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandeep goyal 2003-06-24 03:16:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
There is a particular functionality that we are looking
for in this package. It is called DLMOD functionality (dynamic
loadable modules for SNMP subagents). It seems that this
functionality needs to be enabled at *build* time of the 
package. The default package that shipped with Red hat
advanced server does not support this functionality. 

 When we try to use this functionality, we get a message
saying:
"dlmod: Dynamic modules not support on this platform"



Version-Release number of selected component (if applicable):
ucd-snmp-4.2.1-1

How reproducible:
Always

Steps to Reproduce:
1. Displays the error - dlmod: Dynamic modules not support on this platform
2.
3.
    

Additional info:
Comment 1 Sandeep goyal 2003-06-24 03:23:02 EDT
The version of ucd-snmp is 4.2.4-1 and not 4.2.1-1.
Comment 2 Sandeep goyal 2003-06-24 04:14:16 EDT
The error message can be seen when we add the line:

dlmod <module name> <.so path> 

to the snmpd conf file and start snmpd enabling debug (with -D option) for 
dlmod.

Also, it is verified that when we type snmpd -H, we do not see 'dlmod' in the 
list of configuration directives understood.

 
Comment 3 Phil Knirsch 2003-06-24 04:22:25 EDT
Could you give the packages for Red Hat Linux 7.2 on

http://people.redhat.com/pknirsch/

a try and check if they fix your problem? They actually should. 

Please note that these packages haven't been signed nor gone through our QA yet.

Thanks,

Read ya, Phil
Comment 4 Sandeep goyal 2003-06-25 07:11:58 EDT
I tried using the ucd-snmp version available on 
http://people.redhat.com/pknirsch/
It is working. The only concern that I have is, whether this is an offical 
website of RedHat which we can refer, to download this version ucd-snmp rpm for 
Linux Advanced Server 2.1.
Comment 5 Phil Knirsch 2003-06-25 07:22:29 EDT
It is an official website of Red Hat. The only problem is that those rpms have
not officialy been released by Red Hat and therefore are not supported. There is
an errata pending for Red Hat Linux 7.0, 7.1, 7.2 and 7.3 but it hasn't been
released yet.

Read ya, Phil
Comment 6 Sandeep goyal 2003-06-25 07:39:06 EDT
Impressed with such a fast response. Can you give some idea about the tentative 
time line when Red Hat Advanced server can have official supported release of 
this version of UCD-SNMP library?
Comment 7 Phil Knirsch 2003-06-25 07:50:27 EDT
I would think that either in the next or overnext quarterly update of Red Hat
Advanced Server it should be possible to have a fully QAed and supported version
of ucd-snmp included.

Read ya, Phil
Comment 9 Phil Knirsch 2003-12-09 05:42:23 EST
Errata for ucd-snmp has been released for AS2.1 with a fix for this
problem, closing bug as Errata.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.