Bug 979284 - EAP-6.1 Maven repository contains wrong jcip-annotations-1.0-redhat-3.pom
EAP-6.1 Maven repository contains wrong jcip-annotations-1.0-redhat-3.pom
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Build (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high
: ER5
: EAP 6.1.1
Assigned To: Paul Gier
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 03:18 EDT by Josef Cacek
Modified: 2013-09-16 16:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Some users encountered dependency resolution problems with the IVY dependency manager in a previous version of Red Hat JBoss Enterprise Application Platform 6. The issue was traced to an incorrect artifact reference in the /JBOSS_HOME/net/jcip/jcip-annotations/1.0-redhat-3/jcip-annotations-1.0-redhat-3.pom file. This error has been corrected and the affected dependencies resolve as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:25:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Cacek 2013-06-28 03:18:06 EDT
Issue originally reported by Jesper Skov:
https://community.jboss.org/message/825394#825394

The POM for jcip-annotations (1.0-redhat-3) is incorrect, it contains packaging zip instead of jar.
Comment 3 Fernando Nasser 2013-07-02 12:12:30 EDT
I have created a -redhat-4 that is like -redhat-2
Comment 5 Scott Mumford 2013-07-31 21:52:41 EDT
Adding a draft release note.

The above draft should really contain more specific information that I was unable to discern from this and linked tickets.

Ideally I need to know:

1: If my broad understanding of the problem is correct (ie that an error in a pom file was breaking dependency resolution).

2: Which pom file was this error found in? My local version of EAP-6.1.0 doesn't appear to have any pom files in it and I wasn't able to find any references to a jcip-related zip file in any of the pom files in either the 6.0.1 or 6.1.0 source distributions.

3: Which dependency (if any, based on 1 above) could not be resolved?

4: How and when would this manifest itself to users? When attempting to compile the source? Would it affect all users or just specific users?

Any info or clarification will assist to make the release notes a better, more informative document for our users.
Comment 6 Josef Cacek 2013-08-01 05:26:09 EDT
Scott, the problem was in the EAP Maven repository (http://download.devel.redhat.com/released/JBEAP-6/6.1.0/jboss-eap-6.1.0-maven-repository.zip), which is used by users to develop their applications for the EAP or to rebuild the EAP.

And yes, the wrong POM can break dependency resolution - the reported case was with IVY dependency manager (in file /jboss-eap-6.1.0.GA-maven-repository/net/jcip/jcip-annotations/1.0-redhat-3/jcip-annotations-1.0-redhat-3.pom). I'm not sure if Maven projects reports the same issue as the IVY ones.
Comment 7 Nikoleta Ziakova 2013-08-05 08:40:05 EDT
File jcip-annotations-1.0-redhat-4.pom is correct. 

However maven repository for EAP 6.1.1 ER4 contains both 1.0-redhat-3 and 1.0-redhat-4 versions of jcip-annotations and it could cause problem. 

For example infinispan has defined dependency on jcip-annotations version:
<version.jcipannotations>1.0</version.jcipannotations>
and it is not clear whether 1.0-redhat-3 or 1.0-redhat-4 should be used.
Comment 8 Scott Mumford 2013-08-05 19:50:17 EDT
Have updated the Release Note text with the specific file path.

Nikoleta, wouldn't any problems arising from having ambiguous dependency definitions be a different issue? I thought this bug was about a dependency that called a .zip rather than a .jar? Or did I misunderstand that?
Comment 9 Josef Cacek 2013-08-06 01:50:57 EDT
Scott, the problem was really about zip vs. jar type specified in the POM, but if some component still uses -redhat-3 version with the wrong POM , the issue is still on the table. 

We should include only the corrected version in the client Maven repository.
Comment 10 Nikoleta Ziakova 2013-08-08 02:49:06 EDT
Scott, you understood it correctly but the problem is what Josef wrote and there should be only the -redhat-4 version in maven repo and all artifacts should use the correct version.

I created new BZ with all artifacts that have multiple versions in 6.1.1: https://bugzilla.redhat.com/show_bug.cgi?id=993521
Comment 11 Scott Mumford 2013-08-08 20:37:56 EDT
Took release note out of draft/W.I.P status.
The note will appear in the 6.1.1 Release Notes document.
Comment 12 Paul Gier 2013-08-12 13:15:11 EDT
Removing the duplicate jcip-annotations is going to have to wait until 6.2.0.  The current xmltooling and resteasy poms both depend on the older build of jcip-annotations, and it will be a bit risky to update them at this point.  I think the main problem (incorrect packaging) has been solved in the newer jcip-annotations, so for 6.1.1 we'll include both jcip-annotations versions for compatibility, and we'll have a more permanent fix in 6.2.0.
Comment 13 Paul Gier 2013-08-12 13:36:45 EDT
Can we close this issue and then handle the remaining duplicates in the Maven repo zip for 6.2.0 in bug 993521?
Comment 14 Nikoleta Ziakova 2013-08-13 02:14:16 EDT
The issue with incorrect packaging is fixed. Verified for EAP 6.1.1 ER4.

Note You need to log in before you can comment on or make changes to this bug.