Bug 979341 - policy-transaction demo - JMSBindingTest error - missing dependency
policy-transaction demo - JMSBindingTest error - missing dependency
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity low
: ER6
: ---
Assigned To: Keith Babo
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 05:24 EDT by Pavel Drozd
Modified: 2015-08-02 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Drozd 2013-06-28 05:24:30 EDT
Description of problem:
Following error occures during mvn clean install:

ERROR [org.switchyard.test.SwitchYardRunner] Error while test kit startup
java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.switchyard.test.SwitchYardTestKit.beforeDeploy(SwitchYardTestKit.java:192)
	at org.switchyard.test.SwitchYardTestKit.start(SwitchYardTestKit.java:180)
	at org.switchyard.test.SwitchYardRunner.createTest(SwitchYardRunner.java:65)
	at org.junit.runners.BlockJUnit4ClassRunner$1.runReflectiveCall(BlockJUnit4ClassRunner.java:236)
	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
	at org.junit.runners.BlockJUnit4ClassRunner.methodBlock(BlockJUnit4ClassRunner.java:233)
	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:68)
	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:47)
	at org.junit.runners.ParentRunner$3.run(ParentRunner.java:231)
	at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:60)
	at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:229)
	at org.junit.runners.ParentRunner.access$000(ParentRunner.java:50)
	at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:222)
	at org.junit.runners.ParentRunner.run(ParentRunner.java:300)
	at org.switchyard.test.SwitchYardRunner.run(SwitchYardRunner.java:90)
	at org.apache.maven.surefire.junit4.JUnit4TestSet.execute(JUnit4TestSet.java:59)
	at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.executeTestSet(AbstractDirectoryTestSuite.java:120)
	at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.execute(AbstractDirectoryTestSuite.java:103)
	at org.apache.maven.surefire.Surefire.run(Surefire.java:169)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.apache.maven.surefire.booter.SurefireBooter.runSuitesInProcess(SurefireBooter.java:350)
	at org.apache.maven.surefire.booter.SurefireBooter.main(SurefireBooter.java:1021)
Caused by: java.lang.AssertionError: Failed to resolve artifact 'org.hornetq:hornetq-ra:2.3.0.CR1'.  The artifact must be declared as a dependency in your POM, thereby making it available in your local repository.
	at org.junit.Assert.fail(Assert.java:93)
	at org.switchyard.test.ShrinkwrapUtil.getArchive(ShrinkwrapUtil.java:130)
	at org.switchyard.component.test.mixins.jca.JCAMixIn.deployHornetQResourceAdapter(JCAMixIn.java:214)
	at org.switchyard.component.test.mixins.jca.JCAMixIn.deployResourceAdapters(JCAMixIn.java:133)
	at org.switchyard.quickstarts.demo.policy.transaction.JmsBindingTest.before(JmsBindingTest.java:62)
	... 29 more
Tests run: 2, Failures: 2, Errors: 0, Skipped: 0, Time elapsed: 5.028 sec <<< FAILURE!


Additional info:
The policy-transaction demo itself seems ok. If the tests are skipped, the demo works according to readme.
Comment 1 Anne-Louise Tangring 2013-11-11 13:07:16 EST
Re-test, please.
Comment 2 Pavel Drozd 2013-11-12 05:19:35 EST
The problem with missing dependency is solved, verified in ER6. Problem during "mvn clean install" described in BZ-1016063 still remains.

Note You need to log in before you can comment on or make changes to this bug.