This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 979377 - [rhevm-shell] help of rhevm CLI is misleading
[rhevm-shell] help of rhevm CLI is misleading
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.2.0
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Michael Pasternak
Elena
infra
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 07:18 EDT by Pavel Stehlik
Modified: 2016-02-10 14:18 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-04 06:31:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Stehlik 2013-06-28 07:18:20 EDT
Description of problem:
 There is no chance for client to properly connect to rhevm without additional help from someone else.

 1) man rhevm-shell - completely missing!

 2) rhevm-shell --help - password option is missing!
     (used: rhevm-shell -l https://10.34.63.123:8443/api -I -u admin@internal)
     error: missing configuration variable: password.
     *VERY* intuitive option  '--password'  has to be used 

 3) rhevm-shell;
      help connect :
      connect <url> <username> <password> [command options]
     (used:   connect https://10.34.63.123:8443 admin@internal MY_PASS insecure )
      error: wrong number of arguments, try 'help connect' for help.

 4) https://fqdn:port/docs/en-US/html/Command_Line_Shell_Guide/chap-Quick_Start_Example.html#Quick_Start_Example
   - completely misleading !
 # rhevm-shell -c -url "https://[rhevm-host]/api" -user "[user]@[domain]" -password '[password]'
    (it won't work by any chance)


working command:
rhevm-shell -l https://10.34.63.123:8443/api -I -u admin@internal --password MY_PASS

Version-Release number of selected component (if applicable):
sf17.7 (3.2.z candidate)
rhevm-cli-3.2.0.9-1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. see above
2.
3.

Actual results:
User simply can't use that tool with delivered information. It's extremely problematic to even login to this tool.

Expected results:
clear help + working examples!

Additional info:
Comment 2 Michael Pasternak 2013-06-30 02:11:53 EDT
(In reply to Pavel Stehlik from comment #0)
> Description of problem:
>  There is no chance for client to properly connect to rhevm without
> additional help from someone else.
> 
>  1) man rhevm-shell - completely missing!
> 
>  2) rhevm-shell --help - password option is missing!
>      (used: rhevm-shell -l https://10.34.63.123:8443/api -I -u
> admin@internal)
>      error: missing configuration variable: password.
>      *VERY* intuitive option  '--password'  has to be used 

this option is not available by design from security perspective, password
prompt appears automatically on connect, alternatively password can be
configured via ~/.rhevmshellrc configuration file all this available in the 'help' command.

[RHEVM shell (disconnected)]# help

INTRODUCTION
  
  Welcome to RHEVM-shell. This program is an interactive command-line
  interface into RHEVM Virtualization. You can type any command in 
  the interface below.
  
AVAILABLE COMMANDS
  
    * connect          connect to a oVirt manager
    * exit             quit this interactive terminal
    * help             show help
  
  Type 'help <command>' for any of these commands to show detailed help.
  The first command you probably want to issue is 'help connect' to
  learn how to connect to a oVirt manager.
  
COMMAND SYNTAX
  
  The general format for each command is:
  
    help <command> <command attributes> [command options]
  
  If arguments contain spaces or other reserved characters, you need to
  quote them. You can use single (') and double (") quotes for this. The
  difference between single and double quotes is that within single
  quotes you can't use any single quotes, while in double quotes you can
  use a double quote provided that you escape it with backslash ('\').
  
  Options are always in the long form: --option [value]. The value can
  be optional or mandatory, depending on the command, see command help
  for details.
  
  In addition to the basic command form, the following functionality is
  available:
  
    * You can use the '<', '<<', '>' and '>>' characters to perform
      shell-like redirections to files in the file system.
    * The output of any command can be piped to a shell command with
      the '|' character.
    * Shell commands can be executed by typing a '!' or 'shell' at the 
      beginning of a line.
    * Comments start with '#' and end at the end of a line.
      
EXAMPLES
  
  See 'SUPPORTED HELP FORMATS' section under each command help.
  
CONFIGURATION FILE
  
  oVirt-Shell can be configured with configuration file, configuration file
  ( ~/.rhevmshellrc) automatically created under your home directory (if not
  exist) at first rhevm-shell execution.

> 
>  3) rhevm-shell;
>       help connect :
>       connect <url> <username> <password> [command options]
>      (used:   connect https://10.34.63.123:8443 admin@internal MY_PASS
> insecure )
>       error: wrong number of arguments, try 'help connect' for help.

all options in *all* SHELLs are starts with the '--' prefix, you can also
use auto-completion in the shell for that.

> 
>  4)
> https://fqdn:port/docs/en-US/html/Command_Line_Shell_Guide/chap-
> Quick_Start_Example.html#Quick_Start_Example
>    - completely misleading !
>  # rhevm-shell -c -url "https://[rhevm-host]/api" -user "[user]@[domain]"
> -password '[password]'
>     (it won't work by any chance)

this is not correct, as mentioned above all options in all SHELLs are starts 
with '--' prefix and not '-', please file documentation bug on this.

> 
> 
> working command:
> rhevm-shell -l https://10.34.63.123:8443/api -I -u admin@internal --password
> MY_PASS
> 
> Version-Release number of selected component (if applicable):
> sf17.7 (3.2.z candidate)
> rhevm-cli-3.2.0.9-1.el6ev.noarch
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. see above
> 2.
> 3.
> 
> Actual results:
> User simply can't use that tool with delivered information. It's extremely
> problematic to even login to this tool.
> 
> Expected results:
> clear help + working examples!
> 
> Additional info:

Note You need to log in before you can comment on or make changes to this bug.