Bug 979380 - oo-admin-ctl-app dies in PROD
oo-admin-ctl-app dies in PROD
Status: CLOSED DUPLICATE of bug 972958
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 07:28 EDT by Marek Mahut
Modified: 2015-05-14 20:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 10:46:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Mahut 2013-06-28 07:28:26 EDT
Description of problem:
oo-admin-ctl-app dies when trying to remote an orphan application.

# oo-admin-ctl-app -a mediawiki3 -c destroy -l user_login
    !!!! WARNING !!!! WARNING !!!! WARNING !!!!
    You are about to destroy the mediawiki3 application.
  
    This is NOT reversible, all remote data for this application will be removed.
Do you want to destroy this application (y/n): y
/opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/factory.rb:38:in `[]': can't convert String into Integer (TypeError)
	from /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/factory.rb:38:in `from_db'
	from /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/relations/builders/embedded/many.rb:25:in `block in build'
	from /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/relations/builders/embedded/many.rb:23:in `each'
	from /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/relations/builders/embedded/many.rb:23:in `build'
	from /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/relations/accessors.rb:43:in `create_relation'
	from /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/relations/accessors.rb:26:in `__build__'
	from /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/relations/accessors.rb:120:in `block (2 levels) in get_relation'
	from /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/threaded/lifecycle.rb:125:in `_loading'
	from /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/relations/accessors.rb:115:in `block in get_relation'
	from /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/threaded/lifecycle.rb:84:in `_building'
	from /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/relations/accessors.rb:114:in `get_relation'
	from /opt/rh/ruby193/root/usr/share/gems/gems/mongoid-3.0.21/lib/mongoid/relations/accessors.rb:203:in `block in getter'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.9.17/app/models/application.rb:1138:in `run_jobs'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.9.17/app/models/application.rb:531:in `block in remove_features'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.9.17/app/models/application.rb:1280:in `run_in_application_lock'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.9.17/app/models/application.rb:529:in `remove_features'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.9.17/app/models/application.rb:559:in `destroy_app'
	from /usr/sbin/oo-admin-ctl-app:126:in `<main>'
Comment 1 Marek Mahut 2013-06-28 10:46:01 EDT

*** This bug has been marked as a duplicate of bug 972958 ***

Note You need to log in before you can comment on or make changes to this bug.