Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 979398 - http binding throws NPE if ONE-WAY service is used
Summary: http binding throws NPE if ONE-WAY service is used
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard
Version: 6.0.0 GA
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ER1
: ---
Assignee: Magesh Kumar Bojan
QA Contact: Jiri Sedlacek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-28 12:34 UTC by Jiri Sedlacek
Modified: 2015-10-18 22:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)
reproducer app (1.77 KB, application/x-compressed-tar)
2013-06-28 12:34 UTC, Jiri Sedlacek
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker SWITCHYARD-1571 0 Major Closed HTTP service binding throws NPE if bound with in-only MEP service 2014-06-16 23:52:39 UTC

Description Jiri Sedlacek 2013-06-28 12:34:57 UTC
Created attachment 766555 [details]
reproducer app

If one-way service is used with http binding, NPE is thrown:

ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/http-binding].[HttpGatewayServlet]] (http-localhost/127.0.0.1:8080-1) JBWEB000236: Servlet.service() for servlet HttpGatewayServlet threw exception: java.lang.NullPointerException
	at org.switchyard.component.http.HttpGatewayServlet.handle(HttpGatewayServlet.java:162) [switchyard-component-http-1.0.0.Alpha1.jar:1.0.0.Alpha1]
	at org.switchyard.component.http.HttpGatewayServlet.service(HttpGatewayServlet.java:119) [switchyard-component-http-1.0.0.Alpha1.jar:1.0.0.Alpha1]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:847) [jboss-servlet-api_3.0_spec-1.0.2.Final-redhat-1.jar:1.0.2.Final-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:295)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920)
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_21]


reproducer project is attached.

Comment 1 Jiri Sedlacek 2013-06-28 13:04:41 UTC
problem visible in DR6 (switchyard 1.0.0.Alpha1)

Comment 2 Keith Babo 2013-07-01 17:29:04 UTC
Looks like HttpResponseBindingData is returning null for status when it's not set explicitly, which is triggering the NPE.

I disagree that this is a blocker for Alpha 2 as it only applies to in-only MEPs in one gateway (HTTP).

Comment 3 JBoss JIRA Server 2013-07-02 13:42:03 UTC
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1571

pushed

Comment 5 Jiri Sedlacek 2013-09-16 18:05:11 UTC
verified in ER2

Comment 9 JBoss JIRA Server 2014-06-16 23:52:39 UTC
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1571 to Closed


Note You need to log in before you can comment on or make changes to this bug.