Bug 979447 - Clarify EWS support table in WFK 2.3 release notes draft
Clarify EWS support table in WFK 2.3 release notes draft
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: doc-Release-Notes (Show other bugs)
2.3.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 2.3.0
Assigned To: Petr Penicka
Tomas Repel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 11:01 EDT by mark yarborough
Modified: 2014-01-13 03:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 07:33:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mark yarborough 2013-06-28 11:01:52 EDT
Document URL: 

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information: 

In the draft wfk 2.3 release notes section 3.5 as of 18-jun:

http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_JBoss_Web_Framework_Kit/2.3/html-single/2.3.0_Release_Notes/index.html#ews_compatibility

^^^ the section is called "EWS compat" yet the list
shows what is NOT compatible, which is counter-intuitive
and Burr Sutter reqeusted this bug to correct it.

As reference, the format used in WFK 2.2 is pretty clear:

https://access.redhat.com/site/documentation/en-US/JBoss_Web_Framework_Kit/2.2/html-single/2.2.0_Release_Notes/index.html#idm4102752

Thanks
Comment 1 Petr Penicka 2013-07-02 08:03:45 EDT
Modifying the section to list only incompatible frameworks was intentional. Instead of listing all frameworks (and creating duplicity with the tier lists above), I wanted to simplify and put it the way that "all but the following" are compatible with EWS.

I agree though that it was counterintuitive due to the title. How about changing the title to "Frameworks Incompatible with Red Hat JBoss Enterprise Web Server":

Burr, Mark: Does that work for you? If not, I can still change it to be as it was previously.

Docs stage URL: https://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_JBoss_Web_Framework_Kit/2.3/html/2.3.0_Release_Notes/ews_compatibility.html
Comment 2 Marek Schmidt 2013-07-09 09:19:08 EDT
I believe the original version was more useful for an EWS customer, wanting a concise list of what is actually supported on EWS.
Comment 3 Petr Penicka 2013-07-09 10:19:49 EDT
Ok, I restored the original list (and updated it with newly added frameworks).

Docs stage URL: https://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_JBoss_Web_Framework_Kit/2.3/html/2.3.0_Release_Notes/ews_compatibility.html

Quick check URL: http://file.brq.redhat.com/ppenicka/WFK23_RN_draft/

Note You need to log in before you can comment on or make changes to this bug.