Bug 979454 - error parsing groups from F18 repo
error parsing groups from F18 repo
Status: CLOSED DUPLICATE of bug 980572
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
2.2 Beta
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.2.1
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
Depends On:
  Show dependency treegraph
Reported: 2013-06-28 11:20 EDT by Michael Hrivnak
Modified: 2013-07-12 14:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-12 14:42:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Hrivnak 2013-06-28 11:20:25 EDT
Description of problem:
$ pulp-admin rpm repo create --repo-id=f18 --relative-url=f18 --feed=http://dl.fedoraproject.org/pub/fedora/linux/releases/18/Everything/x86_64/os/ --skip=rpm,drpm

run a sync on the above repo, and it fails when parsing groups with this traceback in pulp.log:

2013-06-28 11:16:49,762 pulp.server.managers.repo.sync:ERROR: Exception caught from plugin during sync for repo [f18]
Traceback (most recent call last):
  File "/home/mhrivnak/git/pulp/platform/src/pulp/server/managers/repo/sync.py", line 155, in _do_sync
    sync_report = importer_instance.sync_repo(transfer_repo, conduit, call_config)
  File "/home/mhrivnak/git/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/importer.py", line 88, in sync_repo
    return self._current_sync.run()
  File "/home/mhrivnak/git/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/sync.py", line 141, in run
  File "/home/mhrivnak/git/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/sync.py", line 441, in get_groups
    self.save_fileless_units(group_file_handle, group.GROUP_TAG, process_func)
  File "/home/mhrivnak/git/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/sync.py", line 485, in save_fileless_units
    to_save = existing.check_repo(wanted, self.sync_conduit.get_units)
  File "/home/mhrivnak/git/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/existing.py", line 36, in check_repo
    sorted_units = _sort_by_type(wanted)
  File "/home/mhrivnak/git/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/existing.py", line 71, in _sort_by_type
    for unit in wanted:
  File "/home/mhrivnak/git/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/sync.py", line 483, in <genexpr>
    wanted = (model.as_named_tuple for model in package_info_generator)
  File "/home/mhrivnak/git/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/repomd/packages.py", line 74, in package_list_generator
    package_info = process_func(element)
  File "/home/mhrivnak/git/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/repomd/group.py", line 61, in process_group_element
    'user_visible': _parse_bool(element.find('uservisible').text),
AttributeError: 'NoneType' object has no attribute 'text'

We are having to guess at what we can expect to be in these XML files with hints from what yum itself looks for, so perhaps we are falsely assuming that the "uservisible" element is always present.
Comment 1 Michael Hrivnak 2013-07-12 14:42:26 EDT

*** This bug has been marked as a duplicate of bug 980572 ***

Note You need to log in before you can comment on or make changes to this bug.