Bug 979576 - Spice windows resizes to span 4 monitors wide after a "yum update"
Spice windows resizes to span 4 monitors wide after a "yum update"
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-vdagent (Show other bugs)
6.4
All Linux
low Severity low
: pre-dev-freeze
: ---
Assigned To: Default Assignee for SPICE Bugs
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 16:29 EDT by hmiles
Modified: 2015-10-05 22:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-09 05:42:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 412163 None None None Never

  None (edit)
Description hmiles 2013-06-28 16:29:15 EDT
Description of problem:
Spice windows resizes to span 4 monitors wide after a "yum update".

Version-Release number of selected component (if applicable):
rhevm-3.2.0-11.33.el6ev.noarch
spice-vdagent-0.12.0-4.el6_4.1.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create a new Server guest as RHEL 6 x86_64
2. Install this guest with RHEL Server 6.4
3. Register the system and then run "yum update"

Actual results:
Packages will update and when it reaches the last package the Spice window will immediately resize to span 4 windows worth of space.
To resolve close out the Spice window and restart the guest.

Expected results:
Spice window would not resize and a restart would not be necessary.

Additional info:
Opened this BZ under spice-qxl-driver-win but if this is incorrect please change it.

List of all packages updated during the latest attempt at reproducing:

Jun 28 10:52:47 Updated: 1:perl-Pod-Escapes-1.04-131.el6_4.x86_64
Jun 28 10:52:53 Updated: 4:perl-libs-5.10.1-131.el6_4.x86_64
Jun 28 10:52:53 Updated: 3:perl-version-0.77-131.el6_4.x86_64
Jun 28 10:52:53 Updated: 1:perl-Module-Pluggable-3.90-131.el6_4.x86_64
Jun 28 10:52:54 Updated: 1:perl-Pod-Simple-3.13-131.el6_4.x86_64
Jun 28 10:53:02 Updated: 4:perl-5.10.1-131.el6_4.x86_64
Jun 28 10:53:02 Updated: libcom_err-1.41.12-14.el6_4.2.x86_64
Jun 28 10:53:02 Updated: libselinux-2.0.94-5.3.el6_4.1.x86_64
Jun 28 10:53:02 Updated: coreutils-libs-8.4-19.el6_4.2.x86_64
Jun 28 10:53:05 Updated: coreutils-8.4-19.el6_4.2.x86_64
Jun 28 10:53:05 Updated: krb5-libs-1.10.3-10.el6_4.3.x86_64
Jun 28 10:53:05 Updated: 1:perl-Locale-Maketext-Simple-0.18-131.el6_4.x86_64
Jun 28 10:53:05 Updated: 1:perl-Params-Check-0.26-131.el6_4.x86_64
Jun 28 10:53:06 Updated: openssl-1.0.0-27.el6_4.2.x86_64
Jun 28 10:53:06 Updated: freetype-2.3.11-14.el6_3.1.x86_64
Jun 28 10:53:07 Updated: libxml2-2.7.6-12.el6_4.1.x86_64
Jun 28 10:53:07 Updated: openldap-2.4.23-32.el6_4.1.x86_64
Jun 28 10:53:07 Updated: 1:perl-Module-Load-0.16-131.el6_4.x86_64
Jun 28 10:53:07 Updated: perl-Module-Load-Conditional-0.30-131.el6_4.x86_64
Jun 28 10:53:07 Updated: 1:perl-Log-Message-0.02-131.el6_4.x86_64
Jun 28 10:53:07 Updated: perl-IO-Compress-Base-2.020-131.el6_4.x86_64
Jun 28 10:53:08 Updated: dbus-glib-0.86-6.el6_4.x86_64
Jun 28 10:53:09 Updated: 1:qt-4.6.2-26.el6_4.x86_64
Jun 28 10:53:10 Updated: module-init-tools-3.9-21.el6_4.x86_64
Jun 28 10:53:10 Updated: 1:perl-Compress-Raw-Zlib-2.020-131.el6_4.x86_64
Jun 28 10:53:10 Updated: 1:perl-Package-Constants-0.02-131.el6_4.x86_64
Jun 28 10:53:10 Updated: libuuid-2.17.2-12.9.el6_4.3.x86_64
Jun 28 10:53:10 Updated: libblkid-2.17.2-12.9.el6_4.3.x86_64
Jun 28 10:53:10 Updated: perl-IO-Compress-Zlib-2.020-131.el6_4.x86_64
Jun 28 10:53:10 Updated: perl-Compress-Zlib-2.020-131.el6_4.x86_64
Jun 28 10:53:10 Updated: 1:perl-IO-Zlib-1.09-131.el6_4.x86_64
Jun 28 10:53:10 Updated: perl-Archive-Tar-1.58-131.el6_4.x86_64
Jun 28 10:53:13 Updated: xulrunner-17.0.7-1.el6_4.x86_64
Jun 28 10:53:14 Updated: perl-Log-Message-Simple-0.04-131.el6_4.x86_64
Jun 28 10:53:14 Updated: perl-Term-UI-0.20-131.el6_4.x86_64
Jun 28 10:53:14 Updated: libcurl-7.19.7-37.el6_4.x86_64
Jun 28 10:53:14 Updated: 1:perl-Object-Accessor-0.34-131.el6_4.x86_64
Jun 28 10:53:14 Updated: libss-1.41.12-14.el6_4.2.x86_64
Jun 28 10:53:14 Updated: 1:perl-Digest-SHA-5.47-131.el6_4.x86_64
Jun 28 10:53:14 Updated: 1:perl-Module-Loaded-0.02-131.el6_4.x86_64
Jun 28 10:53:15 Updated: perl-Test-Harness-3.17-131.el6_4.x86_64
Jun 28 10:53:15 Updated: perl-ExtUtils-MakeMaker-6.55-131.el6_4.x86_64
Jun 28 10:53:15 Updated: 1:perl-ExtUtils-ParseXS-2.2003.0-131.el6_4.x86_64
Jun 28 10:53:15 Updated: 4:perl-devel-5.10.1-131.el6_4.x86_64
Jun 28 10:53:15 Updated: 1:perl-IPC-Cmd-0.56-131.el6_4.x86_64
Jun 28 10:53:15 Updated: perl-File-Fetch-0.26-131.el6_4.x86_64
Jun 28 10:53:15 Updated: 1:perl-Archive-Extract-0.38-131.el6_4.x86_64
Jun 28 10:53:16 Updated: 1:perl-ExtUtils-CBuilder-0.27-131.el6_4.x86_64
Jun 28 10:53:16 Updated: perl-Compress-Raw-Bzip2-2.020-131.el6_4.x86_64
Jun 28 10:53:16 Updated: perl-Module-CoreList-2.18-131.el6_4.x86_64
Jun 28 10:53:16 Updated: gnutls-2.8.5-10.el6_4.2.x86_64
Jun 28 10:53:16 Updated: 1:cups-libs-1.4.2-50.el6_4.4.x86_64
Jun 28 10:53:17 Updated: tzdata-java-2013c-1.el6.noarch
Jun 28 10:53:17 Updated: libnl-1.1.4-1.el6_4.x86_64
Jun 28 10:53:18 Updated: libipa_hbac-1.9.2-82.7.el6_4.x86_64
Jun 28 10:53:18 Updated: libipa_hbac-python-1.9.2-82.7.el6_4.x86_64
Jun 28 10:53:19 Updated: ipa-python-3.0.0-26.el6_4.4.x86_64
Jun 28 10:53:28 Updated: 1:java-1.6.0-openjdk-1.6.0.0-1.61.1.11.11.el6_4.x86_64
Jun 28 10:53:28 Updated: perl-IO-Compress-Bzip2-2.020-131.el6_4.x86_64
Jun 28 10:53:29 Updated: 1:perl-Module-Build-0.3500-131.el6_4.x86_64
Jun 28 10:53:29 Updated: perl-Test-Simple-0.92-131.el6_4.x86_64
Jun 28 10:53:29 Updated: perl-ExtUtils-Embed-1.28-131.el6_4.x86_64
Jun 28 10:53:30 Updated: perl-CPAN-1.9402-131.el6_4.x86_64
Jun 28 10:53:30 Updated: krb5-workstation-1.10.3-10.el6_4.3.x86_64
Jun 28 10:53:31 Updated: util-linux-ng-2.17.2-12.9.el6_4.3.x86_64
Jun 28 10:53:31 Updated: 1:qt-sqlite-4.6.2-26.el6_4.x86_64
Jun 28 10:53:32 Updated: 32:bind-libs-9.8.2-0.17.rc1.el6_4.4.x86_64
Jun 28 10:53:32 Updated: 32:bind-utils-9.8.2-0.17.rc1.el6_4.4.x86_64
Jun 28 10:53:32 Updated: libxml2-python-2.7.6-12.el6_4.1.x86_64
Jun 28 10:53:32 Updated: python-dmidecode-3.10.13-3.el6_4.x86_64
Jun 28 10:53:32 Updated: httpd-tools-2.2.15-28.el6_4.x86_64
Jun 28 10:53:33 Updated: 1:net-snmp-libs-5.5-44.el6_4.2.x86_64
Jun 28 10:53:34 Updated: sssd-client-1.9.2-82.7.el6_4.x86_64
Jun 28 10:53:36 Updated: selinux-policy-3.7.19-195.el6_4.12.noarch
Jun 28 10:53:36 Updated: e2fsprogs-libs-1.41.12-14.el6_4.2.x86_64
Jun 28 10:53:36 Updated: 4:perl-Time-HiRes-1.9721-131.el6_4.x86_64
Jun 28 10:53:36 Updated: 1:perl-parent-0.221-131.el6_4.x86_64
Jun 28 10:53:36 Updated: 1:perl-Parse-CPAN-Meta-1.40-131.el6_4.x86_64
Jun 28 10:53:37 Updated: perl-CPANPLUS-0.88-131.el6_4.x86_64
Jun 28 10:53:37 Updated: perl-Time-Piece-1.15-131.el6_4.x86_64
Jun 28 10:53:37 Updated: libproxy-python-0.3.0-4.el6_3.x86_64
Jun 28 10:53:37 Updated: libproxy-0.3.0-4.el6_3.x86_64
Jun 28 10:53:37 Updated: libproxy-bin-0.3.0-4.el6_3.x86_64
Jun 28 10:53:37 Updated: libsss_autofs-1.9.2-82.7.el6_4.x86_64
Jun 28 10:53:37 Updated: libsss_idmap-1.9.2-82.7.el6_4.x86_64
Jun 28 10:53:38 Updated: upstart-0.6.5-12.el6_4.1.x86_64
Jun 28 10:53:38 Updated: iputils-20071127-17.el6_4.x86_64
Jun 28 10:53:40 Updated: initscripts-9.03.38-1.el6_4.1.x86_64
Jun 28 10:53:41 Updated: sssd-1.9.2-82.7.el6_4.x86_64
Jun 28 10:53:42 Updated: mdadm-3.2.5-4.el6_4.1.x86_64
Jun 28 10:53:43 Updated: subscription-manager-1.1.23.1-1.el6_4.x86_64
Jun 28 10:53:45 Updated: subscription-manager-gui-1.1.23.1-1.el6_4.x86_64
Jun 28 10:53:47 Updated: kernel-firmware-2.6.32-358.11.1.el6.noarch
Jun 28 10:53:55 Installed: kernel-2.6.32-358.11.1.el6.x86_64
Jun 28 10:53:55 Updated: boost-system-1.41.0-17.el6_4.x86_64
Jun 28 10:53:56 Updated: mesa-dri-filesystem-9.0-0.8.el6_4.3.x86_64
Jun 28 10:53:57 Updated: mesa-dri-drivers-9.0-0.8.el6_4.3.x86_64
Jun 28 10:53:57 Updated: mesa-libGL-9.0-0.8.el6_4.3.x86_64
Jun 28 10:53:57 Updated: mesa-libGLU-9.0-0.8.el6_4.3.x86_64
Jun 28 10:54:00 Updated: 1:qt-x11-4.6.2-26.el6_4.x86_64
Jun 28 10:54:00 Updated: 1:phonon-backend-gstreamer-4.6.2-26.el6_4.x86_64
Jun 28 10:54:00 Updated: libtirpc-0.2.1-6.el6_4.x86_64
Jun 28 10:54:01 Updated: 1:autofs-5.0.5-74.el6_4.x86_64
Jun 28 10:54:01 Updated: ipa-client-3.0.0-26.el6_4.4.x86_64
Jun 28 10:54:02 Updated: glx-utils-9.0-0.8.el6_4.3.x86_64
Jun 28 10:54:02 Updated: boost-filesystem-1.41.0-17.el6_4.x86_64
Jun 28 10:54:02 Updated: subscription-manager-firstboot-1.1.23.1-1.el6_4.x86_64
Jun 28 10:54:03 Updated: kexec-tools-2.0.0-258.el6_4.2.x86_64
Jun 28 10:54:03 Updated: vte-0.25.1-8.el6_4.x86_64
Jun 28 10:54:07 Updated: 1:cups-1.4.2-50.el6_4.4.x86_64
Jun 28 10:54:09 Updated: httpd-2.2.15-28.el6_4.x86_64
Jun 28 10:54:09 Updated: 1:net-snmp-5.5-44.el6_4.2.x86_64
Jun 28 10:54:10 Updated: spice-vdagent-0.12.0-4.el6_4.1.x86_64
Jun 28 10:54:10 Updated: perl-core-5.10.1-131.el6_4.x86_64
Jun 28 10:54:10 Updated: e2fsprogs-1.41.12-14.el6_4.2.x86_64
Jun 28 10:54:55 Updated: selinux-policy-targeted-3.7.19-195.el6_4.12.noarch
Jun 28 10:55:06 Updated: 1:java-1.7.0-openjdk-1.7.0.25-2.3.10.3.el6_4.x86_64
Jun 28 10:55:07 Updated: 1:wpa_supplicant-0.7.3-4.el6_3.x86_64
Jun 28 10:55:09 Updated: ghostscript-8.70-15.el6_4.1.x86_64
Jun 28 10:55:10 Updated: curl-7.19.7-37.el6_4.x86_64
Jun 28 10:55:14 Updated: firefox-17.0.7-1.el6_4.x86_64
Jun 28 10:55:16 Updated: yelp-2.28.1-17.el6_3.x86_64
Jun 28 10:55:20 Updated: gnome-power-manager-2.28.3-7.el6_4.x86_64
Jun 28 10:55:21 Updated: mysql-libs-5.1.69-1.el6_4.x86_64
Jun 28 10:55:21 Updated: gzip-1.3.12-19.el6_4.x86_64
Jun 28 10:55:22 Updated: libselinux-utils-2.0.94-5.3.el6_4.1.x86_64
Jun 28 10:55:22 Updated: libselinux-python-2.0.94-5.3.el6_4.1.x86_64
Jun 28 10:55:22 Updated: perl-CGI-3.51-131.el6_4.x86_64
Jun 28 10:55:22 Updated: pixman-0.26.2-5.el6_4.x86_64
Jun 28 10:55:23 Updated: xorg-x11-drv-mach64-6.9.3-4.1.el6_4.x86_64
Jun 28 10:55:23 Updated: gdb-7.2-60.el6_4.1.x86_64
Jun 28 10:55:26 Updated: tzdata-2013c-1.el6.noarch
Jun 28 10:55:26 Updated: 1:dmidecode-2.11-2.el6_1.x86_64
Comment 1 hmiles 2013-06-28 17:03:23 EDT
Host info:

    Red Hat Enterprise Linux Server 6.4
    spice-glib-0.14-7.el6.x86_64
    spice-server-0.12.0-12.el6_4.1.x86_64
    spice-gtk-0.14-7.el6.x86_64
    spice-xpi-2.7-22.el6.x86_64
    spice-vdagent-0.12.0-4.el6_4.1.x86_64
Comment 2 Andrew Cathrow 2013-07-11 22:44:01 EDT
David - is this on the right component?
Comment 3 Alon Levy 2014-05-04 12:12:25 EDT
I see xorg-x11-drv-qxl was not updated ,is that correct? based on that and the fact that spice-vdagent was updated I'm assigning to spice-vdagent.
Comment 5 Marc-Andre Lureau 2014-06-04 08:34:42 EDT
do I understand correctly that the first display get resized to very large size?

can you provide "xrandr" command output from client?

also xrandr from guest before updating, and after updating.

thanks
Comment 7 Marc-Andre Lureau 2014-06-17 16:54:42 EDT
Is anyone able to reproduce? I can't. It may have been an old virt-viewer bug?
Comment 9 Marc-Andre Lureau 2014-10-09 05:42:36 EDT
closing for now as it can't be reproduced, feel free to reopen if you have further details

Note You need to log in before you can comment on or make changes to this bug.