Bug 979582 - nectar should compensate for servers that send wrong content-encoding header
nectar should compensate for servers that send wrong content-encoding header
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: z_other (Show other bugs)
2.2 Beta
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.2.0
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 16:41 EDT by Michael Hrivnak
Modified: 2013-09-10 11:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 11:44:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Hrivnak 2013-06-28 16:41:02 EDT
The following bug details the type of broken http server that causes a problem:

https://fedorahosted.org/fedora-infrastructure/ticket/3859

In this case, where most download clients (curl, chrome, firefox, etc) will download a gzipped file and leave it compressed, the "requests" library follows the letter of RFC2616 and unzips the file. This causes a problem for us, because the code requesting a download expects to find a file that is still gzipped.

This caused a complete failure to sync a fedora 18 repo. (link in the bug listed above)

Nectar should thus make some intelligent decisions about ignoring the content-encoding header when its value is "x-gzip" and the file ends in '.gz'.
Comment 1 Michael Hrivnak 2013-07-01 16:01:02 EDT
https://github.com/pulp/nectar/pull/5
Comment 2 Jeff Ortel 2013-07-03 18:11:16 EDT
build: 2.2.0-18.beta
Comment 3 Jeff Ortel 2013-07-03 18:14:53 EDT
Correction:

build: 2.2.0-0.18.beta
Comment 4 Preethi Thomas 2013-07-10 02:19:29 EDT
verified
[root@ibm-x3550m3-11 ~]# rpm -qa |grep pulp-server
pulp-server-2.2.0-0.20.beta.fc18.noarch
[root@ibm-x3550m3-11 ~]# 


[root@ibm-x3550m3-11 ~]# pulp-admin repo list
+----------------------------------------------------------------------+
                              Repositories
+----------------------------------------------------------------------+




Id:                  f18
Display Name:        f18
Description:         None
Content Unit Counts: 
  Package Category:       12
  Package Group:          151
  Rpm:                    33863
  Yum Repo Metadata File: 1
Comment 5 Preethi Thomas 2013-09-10 11:44:57 EDT
2.2 released
http://repos.fedorapeople.org/repos/pulp/pulp/stable/2.2/

Note You need to log in before you can comment on or make changes to this bug.