This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 979583 - pulp-admin consumer says you can bind, but you cannot
pulp-admin consumer says you can bind, but you cannot
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.2.1
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 16:42 EDT by Randy Barlow
Modified: 2013-12-09 09:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 09:37:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2013-06-28 16:42:14 EDT
The consumer section in pulp-admin says that you can bind consumers, but you cannot. We should remove "bind" from its help text.

$ pulp-admin consumer
Usage: pulp-admin [SUB_SECTION, ..] COMMAND
Description: register, bind, and interact with consumers
Comment 1 Michael Hrivnak 2013-07-05 16:01:09 EDT
It looks like this was already fixed here: https://github.com/pulp/pulp/commit/510c963

$ pulp-admin consumer
Usage: pulp-admin [SUB_SECTION, ..] COMMAND
Description: display and manage Pulp consumers

Available Commands:
  history    - displays the history of operations on a consumer
  list       - lists a summary of consumers registered to the Pulp server
  search     - search consumers
  unregister - unregisters a consumer
  update     - changes metadata on an existing consumer
Comment 2 Jeff Ortel 2013-11-01 14:50:28 EDT
build: 2.2.1-0.1.beta
Comment 3 Preethi Thomas 2013-11-08 13:58:38 EST
[root@pulp-v2-server ~]# rpm -qa pulp-server
pulp-server-2.2.2-1.el6.noarch
[root@pulp-v2-server ~]# pulp-admin consumer
Usage: pulp-admin [SUB_SECTION, ..] COMMAND
Description: display and manage Pulp consumers

Available Commands:
  history    - displays the history of operations on a consumer
  list       - lists a summary of consumers registered to the Pulp server
  search     - search consumers
  unregister - unregisters a consumer
  update     - changes metadata on an existing consumer
[root@pulp-v2-server ~]#
Comment 4 Preethi Thomas 2013-12-09 09:37:00 EST
Released pulp 2.2.1

Note You need to log in before you can comment on or make changes to this bug.